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1. Preface
1.1. Motivation

While tools for the automated analysis of MS and LC-MS/ MS data are continuously improving, it is still 
often the case that at the end of an experiment, the mass spectrometrists will spend time carefully 
examining individual spectra. Current software support is mostly provided only by the instrument 
vendors, and the available software tools are often instrument-dependent. Such software can only be used 
to analyze data from a specific instrument, and this causes serious problems for laboratories that use more 
than one instrument.  This tight software-instrument relationship also causes problems for laboratories that 
do not possess their own instruments, and have to obtain mass spectra from other, collaborating, 
laboratories. To provide a solution to these limitations I have started to develop mMass - open source 
multi-platform tool for precise mass spectrometric data analysis and interpretation.

1.2. Authors

mMass is the fruit of years of study and development.  While I’ve put a lot of energy into making this 
program as stable and reliable as possible, mMass comes with no warranty of any kind. You are however 
welcome to read the code, modify it and send me any suggestions or patches. mMass development still 
continues, so any ideas,  function requests or bug reports are more than welcome. Feel free to contact me 
through the mMass’s web page http://www.mmass.org or join the forum at http://forum.mmass.org.

 Martin Strohalm, PhD: Laboratory of Molecular Structure Characterization
  Institute of Microbiology, Prague
  Academy of Sciences of the Czech Republic
  http://ms.biomed.cas.cz
  http://www.mmass.org

I wish to express my thanks to all the people involved in the excellent Python language, wxPython and 
NumPy libraries, and namely to the people helping me to make mMass still better:

 Daniel Kavan, PhD:  C programing
  Laboratory of Molecular Structure Characterization
  Institute of Microbiology, Prague
  Academy of Sciences of the Czech Republic
  http://ms.biomed.cas.cz

 Sebastian Gibb:  OpenSUSE packages
  Universität Leipzig, Germany

 Filippo Rusconi, PhD:  Debian packages
  Laboratoire de Biophysique - INSERM - CNRS - MNHN, France

 Petr Novák, PhD:
 Petr Man, PhD:
 Michael Volný, PhD:
 Petr Pompach, PhD: Mass spectrometry consultations
  Laboratory of Molecular Structure Characterization
  Institute of Microbiology, Prague
  Academy of Sciences of the Czech Republic
  http://ms.biomed.cas.cz

1.3. Publications to Cite

• Strohalm M, Kavan D, Novák P, Volný M, Havlíček V: mMass 3: A Cross-Platform Software 
Environment for Precise Analysis of Mass Spectrometric Data. Anal Chem 82 (11), 4648-51 (2010). 
DOI:10.1021/ac100818g
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• Strohalm M, Hassman M, Košata B, Kodíček M: mMass data miner: an open source alternative for 
mass spectrometric data analysis. Rapid Commun Mass Spec 22 (6), 905-908 (2008). 
DOI:10.1002/rcm.3444

1.4. Technicalities

At the very beginning mMass started as a simple PHP-based tool to compare peak differences within 
mass spectrum. Fortunately, PHP wasn’t powerful enough for calculations and I stated to learn Python... 

Current version of mMass is written completely in Python programing language (http://www.python.org) 
and uses wxPython libraries (http://www.wxpython.org) for graphical user interface (GUI). In addition, 
NumPy module (http://www.numpy.org) is used for faster computing of mathematical tasks. 

Since resolution of modern mass spectrometers grows up,  resulting data sets become very large. Even 
Python is not powerful enough for some calculations,  therefore a piece of code written in C has been 
added into mMass to speed-up a spectrum drawing.

1.5. Typographical Conventions

Following typographical conventions are used throughout this document:

Names of mMass’s components and modules, names of dialog values etc.

Menu items and buttons.

Terminal commands, scripts and other pieces of code.

Advanced tips and hints.

Important notes and warnings.
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2. Version History
Version 3.9.0 (released Dec 15, 2010)

• New: Compare Peak Lists tool to compare peak lists between multiple documents.
• New: Simple math functions are now available to add, subtract and multiply spectra.
• New: Peptides, fragments or compounds lists can be filtered to show matched/unmatched items only.
• New: Sequences from digest list, fragments list or peptide search list can be copied into clipboard.
• New: Duplicate copy of selected document can be make via pop-up menu in Documents Panel.
• New: Distance measurement tool shows current distance in both m/z and ppm (in bottom bar only).
• Improved: Multiple documents can be opened at once using Open dialog.
• Fixed: Correct drawing of spectra with no continuous baseline (typically for SIM experiments).
• Fixed: FWHM and resolution columns in a peak list can now be copied into clipboard as well.
• Fixed: Option to enable/disable notation marks now works correctly.

Version 3.8.0 (released Aug 20, 2010)

• New: TIC and BPC chromatograms are now available in scan selection dialog.
• New: Support for mzML data format.
• New: Spectrum intensity offset (visual only) can now be set either manually or using new mouse tool. 
• New: Intensity bar is now available in Spectrum Panel.
• New: Height of position bar and intensity bar can now be set in Canvas Properties.
• New: New view option to show/hide spectrum data points.
• Improved: Peak width is assigned automatically when overlaying theoretical isotopic patterns.
• Fixed: Incorrect charge calculation in Deisotoping module.
• Fixed: Incorrect file extension for files converted by CompassXport.

Version 3.7.0 (released Jul 19, 2010)

• New: Simplified interface for Protein Prospector tools MS-Fit and MS-Tag.
• New: FWHM and resolution is now calculated for each peak and shown in Peaklist Panel.
• New: Global modifications can now be stored as presets.
• New: Spectrum polarity can now be set in Document Info panel.
• Fixed: Application crashed when "None" document was sent into Calibration Panel.
• Fixed: Some of the potential peaks were skipped in Shoulder Peaks Removal algorithm.
• Fixed: Data matching for negative spectra was not possible with Ignore charge option unchecked.

Version 3.6.0 (released Jul 5, 2010)

• New: Match Summary is now available for each data matching.
• New: Remove shoulder peaks option is now available for FTMS data peak-picking.
• New: All annotations and sequence matches can now be removed at once from Document panel.
• New: Compounds and calibration masses can now be imported using corresponding library editor.
• Improved: Faster peak-picking, especially when Adaptive threshold option is used.
• Improved: Spectrum flipping is now accessible from the View menu.
• Fixed: Loading of some mzXML files with parameter "compressionType=none" was not possible.
• Fixed: Application crashed on a single right-click in Isotopic pattern panel.

Version 3.5.0 (released Jun 4, 2010)

• New: Possibility to vertically flip spectra in Spectrum Viewer.
• New: -H2O can now be searched in Compounds Search tool.
• Fixed: Normalized view did not worked for non-profile spectra.

Version 3.4.0 (released May 12, 2010)

• New: Radical ions can now be calculated in Mass Calculator and Compounds Search tools.
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• New: Single-point linear calibration has been enabled.
• New: Calibration curve is now shown in the calibration error plot.
• New: Current peak list is now shown as a background in error plots (calibration, data matching).
• New: New view option to enable/disable normalized view of opened documents.
• New: New view option to enable/disable notation marks.
• New: All annotations and matches can now be highlighted by selecting a document root.
• New: Theoretical and matched sequence coverage is now shown in Protein Digest tool.
• New: Final composition of ion is validated in ion series calculations.
• New: Automatic checking for available updates has been added.
• New: Application preferences for updates and compassXport utility has been added.
• Fixed: Mass Calculator - calculation of ions with negative agent charge.
• Fixed: Mass Calculator - pattern modeling with complex charging agent.
• Fixed: Normalization now includes baseline shift.

Version 3.3.0 (released Apr 9, 2010)

• New: Periodic Table of the elements has been added.
• New: Bruker's raw data are imported using CompassXport tool (MSW only).
• Fixed: Small fixes in manual peak picking.
• Fixed: Dragging documents to mMass caused the source window to freeze until data were not loaded.
• Fixed: Mass Search tool - Enzyme endings selection did not worked.
• Fixed: Mass Search tool - Max charge has been replaced by Charge.
• Improved: Mass Search tool - better filtering.

Version 3.2.0 (released Mar 14, 2010)

• New: Isotopic Pattern panel is now collapsable.
• New: Hidden modifications can now be enabled in Mascot Search interface.
• New: Modified documents are marked by asterisk.
• Improved: Relative intensity for annotations and matches is now calculated on-the-fly.

Version 3.1.0 (released Mar 3, 2010)

• New: Lipid database (by LIPID MAPS Consortium) has been added to Compounds Search tool.
• New: ProFound Search interface has been implemented.
• New: Sequences can now be imported form mMass’s and FASTA files.
• New: Manually labeled peak can now be automatically set as monoisotopic.
• New: Specific cursor images for spectrum tools has been added.
• New: Scan list buffer is now used to speed-up loading of multi-scan documents.
• Fixed: Multiple fixes in Mascot Search interface.
• Improved: Peak-picking algorithm has been improved.
• Improved: More "Pythonic" syntax in the mspy module.
• Improved: Spectrum tools are now accessible from the main menu as well.

Version 3.0.0 (released Feb 1, 2010)

• Complete mMass redesign - new user interface, new features and new source code architecture.
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3. License
This program and its documentation are Copyright © 2005-10 by Martin Strohalm.

This program is free software; you can redistribute it and/or modify it under the terms of the GNU 
General Public License as published by the Free Software Foundation. See the file LICENSE.TXT for 
details (and make sure that you have entirely read and understood it!)

Please note in particular that, if you use this program, or ANY part of it - even a single line of code - in 
another application, the resulting application becomes also GPL. In other words, GPL is a 
"contaminating" license. 

If you do not understand any portion of this notice, please seek appropriate professional legal advice.  If 
you do not or - for any reason - you can not accept ALL of these conditions, then you must not use nor 
distribute this program.

This program is distributed in the hope that it will be useful, but WITHOUT ANY WARRANTY; without 
even the implied warranty of MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE.  
See the GNU General Public License (http://www.gnu.org).

The origin of this software must not be misrepresented; you must not claim that you wrote the original 
software. Altered source versions must be clearly marked as such, and must not be misrepresented as 
being the original software. This notice must not be removed or altered from any source distribution.
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4. Installation
4.1. Mac OS X

As usually, there is no special installation procedure for Mac OS X. mMass is available as a regular disk 
image containing the “mMass.app” application. This is a standalone package containing all the necessary 
modules and libraries. To install mMass just open the disk image and drag the mMass.app to your 
application folder.  After first run mMass creates the specific folder “~/Library/Application Support/
mMass/” to store all your presets and objects libraries. Current version of mMass was successfully tested 
on the Intel based computers with Mac OS X 10.5 and 10.6.

mMassʼs installation disk image for Mac OS X.

4.2. MS Windows

In most cases, installation on MS Windows is very easy.  mMass is available as regular ZIP archive 
containing the “mMass”  application folder. There are no installation steps needed to run mMass under 
MS Windows. This means that you can run the program directly after unpacking downloaded archive. 
Simply run the “mmass.exe”. Current version of mMass was successfully tested on XP SP3,  Vista and 
Windows7.

Please note that you must have the privileges for writing to the “mMass” folder, otherwise you will 
not be able to store any program presets such as startup defaults, modifications etc..

Do not try to associate any file type with mMass on MS Windows since it does not work properly. 
Instead of adding document to the running instance of mMass, every document will be opened within 
a new instance of the program.

For older versions of MS Windows, mMass sometimes doesn’t want to start up showing the following 
message instead: The application failed to start because the application configuration is incorrect. 
Reinstalling the application may fix this problem.  In such a case you’ll need to download and install the 
runtime components of Visual C++ Libraries from Microsoft's website.

http://www.microsoft.com/downloads/details.aspx?
familyid=9B2DA534-3E03-4391-8A4D-074B9F2BC1BF&displaylang=en

mMass User’s Guide

© 2010 Martin Strohalm  Page 10

http://www.microsoft.com/downloads/details.aspx?familyid=9B2DA534-3E03-4391-8A4D-074B9F2BC1BF&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=9B2DA534-3E03-4391-8A4D-074B9F2BC1BF&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=9B2DA534-3E03-4391-8A4D-074B9F2BC1BF&displaylang=en
http://www.microsoft.com/downloads/details.aspx?familyid=9B2DA534-3E03-4391-8A4D-074B9F2BC1BF&displaylang=en


4.3. Linux

I have to say that I’m not very familiar with Linux platform and therefore there is no special build of 
mMass available for Linux. Nevertheless,  I am always testing and debugging mMass on my virtual 
version of Debian distribution to make it work properly and to retain application native look. If you want 
to run mMass on Linux see the following chapter to run it from the source code.

4.4. Running from Source

mMass belongs to the wide family of open source software so why not to modify it? All you need to do is 
download and unpack the mMass’s source ZIP archive and then do what you can. There are some 
additional modules and libraries needed to run mMass,  however, all of them are available for free and 
easy to install.

Dependencies

Python (http://www.python.org) “Python is a programming language that lets you work more quickly 
and integrate your systems more effectively. You can learn to use Python and see almost immediate gains 
in productivity and lower maintenance costs.”

wxPython (http://www.wxpython.org) “wxPython is a GUI toolkit for the Python programming 
language. It allows Python programmers to create programs with a robust,  highly functional graphical 
user interface, simply and easily. It is implemented as a Python extension module (native code) that wraps 
the popular wxWidgets cross platform GUI library, which is written in C++.”

NumPy (http://www.numpy.org) “NumPy is the fundamental package needed for scientific computing 
with Python.  It contains among other things: a powerful N-dimensional array object, sophisticated 
(broadcasting) functions, tools for integrating C/C++ and Fortran code, useful linear algebra, Fourier 
transform, and random number capabilities.”

Please note that current version of mMass was developed and tested using Python 2.6, wxPython 
2.8.10.1 and NumPy 1.4.  I cannot guarantee that mMass will work with different version of 
particular libraries.

Compiling C-code

In addition to installing all of the above libraries and modules you’ll need to compile a piece of C code 
used to speed up spectrum drawing. It can be done very easily with the “setup.py” script located in 
“mspy/plot/” folder.

On Mac OS X go to the “mspy/plot/” folder and run compilation command in Terminal, then locate 
resulted “calculations.so” file in the build folder and move it to “mspy/plot/”. The compilation command 
should be like:

python setup.py build

On MS Windows go to the “mspy/plot/” folder and run compilation command in Command Prompt, then 
locate resulted “calculations.pyd”  file in the build folder and move it to “mspy/plot/”. If you are using 
MinGW (http://www.mingw.org) the compilation command should be like:

python setup.py build --compiler=mingw32

On Linux go to the “mspy/plot/” folder and run compilation command in Terminal, then locate resulted 
“calculations.so” file in the build folder and move it to “mspy/plot/”. The compilation command should 
be like this:
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python setup.py build

Running Application

To start up mMass go to mMass’s main folder and simply run the following command:

python mmass.py

Making Application Bundle

If you want to make your own application bundle for Mac OS X or MS Windows you need to have 
py2app (http://pypi.python.org/pypi/py2app) or py2exe (http://pypi.python.org/pypi/py2exe) respectively. 
After installing the corresponding utility you can make the bundle simply by using “setup.py” script 
located in mMass’s main folder. Just go to the folder and run the following command:

On Mac OS X

python setup.py py2app

On MS Windows

python setup.py py2exe
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5. User Interface
5.1. Application Layout

Beside the standard elements,  like toolbar etc., mMass’s user interface is divided into three main parts: 
Documents Panel, Spectrum Viewer and Peaklist Panel. All the processing and analyzing modules and 
tools are available as floating panels to enable direct validation of results with acquired data.

highlight m/z
intensity bar

peaklist panel

peak editorspectrum toolsview optionsdocuments panel

main toolbar spectrum viewer
gel view

position bar

mMassʼs user interface.

5.2. Main Menu

File

New - creates a blank document with no data.

Open - opens document.

Open Recent - opens one of the recent documents.

Close - closes selected document.

Close All - closes all opened documents.

Save - saves selected document into mMass’s native format.

Save As - saves selected document as a new file.

Export - exports current spectrum image, spectrum points or peak list.

Print Spectrum - prints current spectrum view.

Analysis Report - generates analysis report for selected document.
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Preferences - shows application preferences dialog. (Moved to mMass menu on Mac OS X.)

Document Info - shows document information panel for selected document.

View

Show/Hide Gridlines - shows or hides gridlines in spectrum viewer.

Show/Hide Legend - shows or hides legend in spectrum viewer.

Show/Hide Position Bar - shows or hides position bar in spectrum viewer.

Show/Hide Intensity Bar - shows or hides intensity bar in spectrum viewer.

Show/Hide Gel - shows or hides gel-view in spectrum viewer.

Show/Hide Gel Legend - shows or hides legend in gel-view.

Show/Hide Cursor Tracker - shows or hides cursor tracker in spectrum viewer.

Show/Hide Data Points - shows or hides spectrum data points on detailed zoom.

Show/Hide Labels - shows or hides peak labels in spectrum viewer.

Show/Hide Labels Ticks - shows or hides ticks for peak labels.

Show/Hide Labels Charge - shows or hides charge value for peak labels.

Show/Hide Labels Background - shows or hides a solid white background for peak labels.

Show/Hide Notation Marks - shows or hides marks for annotated or matched peaks.

Horizontal/Vertical Labels - shows peak labels horizontally or vertically.

Overlapping/Non-Overlapping Labels - enables or disables automatic managing of labels overlaps.

Labels in All Documents - shows or hides peak labels in all visible spectra.

Autoscale Intensity - enables or disables automatic scaling of intensity axis.

Normalize Intensity - enables or disables normalization of intensity axis for all spectra.

Flip Spectrum - flips selected spectrum vertically.

Offset Spectrum - specifies intensity offset for current spectrum.

Clear Offsets - clears intensity offsets for all spectra.

Canvas Properties - additional options for spectrum canvas (gel height, mass precision, font sizes etc.).

Processing

Undo - reverts back last operation. Most of the operations in mMass can be undone such as all processing 
functions or editing of labels, matches and annotations. One step back is currently available.

Peak Picking - automatically finds and labels peaks in selected document.

Deisotoping - automatically assigns charges and deletes isotopes in current peak list. 
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Correct Baseline - corrects baseline in selected spectrum.

Smooth Spectrum - smooths selected spectrum.

Crop - crops spectrum points and peak list in selected document.

Math Operations - add, subtract or multiply selected spectrum. 

Calibration - calibrates data in selected document using internal, external or statistical calibration.

Normalize Data - normalizes data in selected document to 0 - 100% intensity range.

Swap Data - swaps data between spectrum and peak list in selected document.

Sequence

New - creates new sequence object in selected document.

Import - imports sequence object from a file into selected document.

Edit Sequence - shows sequence editor with selected sequence.

Edit Modifications - shows sequence modifications editor with selected sequence.

Digest Protein - generates digestion peptides from selected sequence.

Fragment Peptide - generates fragments from selected sequence.

Mass Search - searches for peptide corresponding to given m/z value within selected sequence.

Calibrate by Matches - uses current sequence matches as reference masses for data re-calibration.

Delete Matches - deletes all the matches for selected sequence.

Delete Sequence - deletes selected sequence object.

Sort By Titles - sorts all sequences in selected document by titles.

Tools

Label Peak - sets mouse tool to label peaks in selected spectrum.

Label Point - sets mouse tool to label exact points in selected spectrum.

Delete Label - sets mouse tool to delete labels in selected spectrum.

Measure Distances - sets mouse tool to measure distances between two peaks in a spectrum.

Offset Spectrum - sets mouse tool to offset spectrum intensity.

Periodic Table - shows periodic table of elements.

Mass Calculator - calculates ion series and isotopic pattern for specified molecular formula.

Compounds Search - searches for specified compounds and adducts within selected document.

Peak Differences - generates table of peak differences to searches for amino acids or any m/z difference.

Compare Peak Lists - compare multiple peak lists.
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Mascot Peptide Mass Fingerprint - sends selected peak list to Mascot’s Peptide Mass Fingerprint tool.

Mascot MS/MS Ion Search - sends selected peak list to Mascot’s MS/MS Ion Search tool.

Mascot Sequence Query - sends selected peak list to Mascot’s Sequence Query tool.

ProFound Search - sends selected peak list to ProFound Search tool.

Protein Prospector MS-Fit - sends selected peak list to Protein Prospector MS-Fit Search tool.

Protein Prospector MS-Tag - sends selected peak list to Protein Prospector MS-Tag Search tool.

Libraries

Modifications - shows modifications library editor.

Enzymes - shows shows enzymes library editor.

Compounds - shows compounds library editor.

Calibration Masses - shows calibration masses library editor.

Mascot Servers - shows Mascot servers library editor.

Presets - shows presets library editor.

Help

Homepage - opens mMass’s website in a default web browser.

Check for updates - checks for available updates.

Paper to Cite - shows related papers in a default web browser.

Donate - shows donation website in a default web browser.

5.3. Toolbar

To retain platform conventions and user experience there are two slightly different toolbars.  In contrast to 
Linux and MS Windows, on Mac OS X there are no individual buttons for common document operations 
such as Open, Save, Print etc. and all related tools are grouped into a single button such as Processing or 
Sequence. The Search filed is available on Mac OS X to highlight selected m/z value in a spectrum.

processing tools
calibration

sequence tools
mass calculator

mascot search tools
profound search highlight m/z

compare peak lists
peak differences

compounds search

document info and notes
analysis report

data export

Main application toolbar on Mac OS X platform.
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open document
save document

print spectrum

peak picking
deisotoping

calibration

mass calculator
compounds search

peak differences

data crop
math operations

baseline correction
spectrum smoothing

document info and notes
analysis report

data export

seq. editor
protein digestion
peptide fragmentation

search by mass

compare peak lists
mascot search tools

profound search

Main application toolbar on MS Windows and Linux platforms.

5.4. Documents Panel

The main purpose of Documents Panel is to provide a structured view of loaded documents with all its 
sub-elements. In this panel, each element of selected document can be edited by double-clicking or 
processed via specific command or context menu. Most of the sequence related functions are also 
available via the main menu Sequence.

add blank document or sequence
delete item

spectrum colour and visibility bullet

user annotations

sequence matches

sequence title

document title

peak m/z, (match error) and annotation

Documents Panel.

Document

➡ To add blank document:
Press  button from the bottom toolbar and select New Document,  or choose File → New from the 
main menu.

➡ To select document for analysis:
Click on any sub-element of the document you want to select. Regardless of a document color, when 
document is selected all labels ticks are shown in red. Selected document is marked by a bold title.

➡ To make a document copy:
Right-click on the document title and choose Duplicate Document.

➡ To temporarily hide document in spectrum viewer:
Click on a color bullet next to document title.

➡ To change document title, information or notes:
Double-click on the document title, or choose File → Document Info  from the main menu to show 
up Document Info panel. See Document Information chapter for more details.
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➡ To vertically flip document in spectrum viewer:
Right-click on the document title and choose Flip Spectrum, or choose View → Flip Spectrum from 
the main menu.

➡ To offset spectrum intensity in spectrum viewer:
Right-click on the document title and choose Offset Spectrum, or choose View → Offset Spectrum 
from the main menu to show up offset dialog. Set Intensity offset and press Offset button.

➡ To clear spectrum offset:
Right-click on the document title and choose Clear Offset. Choose View → Clear Offsets from the 
main menu to clear offset for all documents.

➡ To change document color:
Right-click on the document title and choose Change Colour.

➡ To delete all annotations and sequence matches:
Right-click on the document title and choose Delete All Notations.

➡ To close document:
Right-click on the document title and select Close Document, press  button from the bottom 
toolbar and choose Close Document, or choose File → Close from the main menu.

➡ To close all documents:
Press  button from the bottom toolbar and choose Close All Documents, or choose File → Close 
All from the main menu.

Please note that spectrum offset is applied only if normalization is disabled.

Please note that normalization and spectrum offset do not modify any document data. These are just 
visualization tools.

User Annotations

It is possible to add user annotations to any peak in a peak list.  You can specify annotation Label, which is 
then shown in Documents Panel, and assign molecular Formula and Theoretical m/z value.  All the 
annotations with theoretical m/z value can be used as calibration standards to re-calibrate your data. If the 
molecular formula is specified you can generate its isotopic pattern to see the difference between 
theoretical and measured peak.

Annotation dialog.

➡ To add user annotation:
Double-click on the peak in Peaklist Panel or press  button from the bottom toolbar of Peaklist 
Panel to show up annotation dialog and type your annotation.
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➡ To edit user annotation:
Double-click on the annotation to show up annotation dialog and edit the annotation.

➡ To delete user annotation:
Right-click on any annotation and select Delete Annotation, or press  button from the bottom 
toolbar and choose Delete Annotation.

➡ To delete all user annotations:
Right-click on any annotation or the annotations root and select Delete All Annotations,  or press  
button from the bottom toolbar and choose Delete All Annotations.

➡ To highlight user annotation in spectrum viewer:
Click on the annotation and spectrum moves to the m/z value. Small red arrow shows up on m/z axis 
of the spectrum.

➡ To show isotopic pattern of user annotation:
Right-click on the annotation and select Show Isotopic Pattern. Mass Calculator panel shows up 
with the annotation formula and corresponding peak charge. This function is available only if 
molecular formula and charge is specified in annotation dialog. See Mass Calculator chapter for 
more information.

➡ To re-calibrate data by user annotations:
Right-click on any single annotation or annotations root and select Calibrate by Annotations.  All the 
user annotations will be send to Calibration panel. Only those annotations with specified theoretical 
m/z value can be used for data calibration. See Calibration chapter for more information.

Sequence

In order to use some mMass’s tools such as Protein Digest or Peptide Fragmentation, specific sequence 
object must be defined. All sequence matches are stored in the similar way as user annotations and there 
are the same features available as well. See Sequence Tools chapter for more information about sequence 
editing and processing.

➡ To add new sequence:
Press  button from the bottom toolbar and select New Sequence,  or choose Sequence → New 
Sequence from the main menu. See Sequence Tools chapter for more information.

➡ To edit sequence:
Double-click on the sequence title and Sequence Editor shows up. See Sequence Tools chapter for 
more information.

➡ To delete sequence:
Click on the sequence title and press Command+Backspace or Delete, or press  button from the 
bottom toolbar and choose Delete Sequence.

➡ To edit sequence match:
Double-click on the sequence match to show up annotation dialog and edit the annotation.

➡ To delete sequence match:
Right-click on any sequence match and select Delete Match,  or press  button from the bottom 
toolbar and choose Delete Match.

➡ To delete all sequence matches:
Right-click on any sequence match or the sequence title and select Delete All Matches, or press  
button from the bottom toolbar and choose Delete All Matches.

➡ To highlight sequence match in spectrum viewer:
Click on the sequence match and spectrum moves to the m/z value. Small red arrow shows up on m/
z axis of the spectrum. Current zoom range remains the same.
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➡ To show isotopic pattern of sequence match:
Right-click on the sequence match and select Show Isotopic Pattern. Mass Calculator panel shows 
up with the peptide formula and corresponding peak charge. See Mass Calculator chapter for more 
information.

➡ To re-calibrate data using sequence matches:
Right-click on any single match or sequence title and select Calibrate by Matches. All the matches 
will be send to Calibration panel. See Calibration chapter for more information.

5.5. Spectrum Viewer

Since most time in data interpretation is spent manipulating spectra (e.i. moving, shifting,  scaling, 
zooming etc.), I aimed to make these functions as easy and user friendly as possible. There are no specific 
buttons or menu items hidden deep inside an application menu just to zoom spectrum. Everything is 
accessible by mouse, keyboard or combination of both. Vertical flipping, spectrum offset and gel view 
can be used to effectively compare your samples with any standard or blank spectrum. In addition, 
Spectrum Viewer not only provides for spectrum visualization, but also offers some other useful features 
such as peak labeling and distance measurements.

gel view position bar
document title

intensity bar

m/z charge cursor tracker

label tick

m/z
intensity

monoisotopic mark

annotation mark

baseline mark
cursor position

spectrum toolsview options

Spectrum Viewer panel.

Spectrum Manipulations

➡ To zoom spectrum range:
Select the m/z range with right or middle mouse button pressed. (Use Ctrl key to substitute right 
mouse button on Mac OS X.)

➡ To zoom continuously from cursor position:
Move the mouse cursor to desired m/z position and scroll the mouse wheel while holding Alt or Ctrl 
key.

➡ To zoom from the center of current view:
Use Left and Right arrows keys on your keyboard while holding Alt key.
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➡ To zoom from the start of current view:
Drag the m/z axis horizontally with right mouse button pressed.

➡ To move spectrum horizontally:
Scroll the mouse wheel or drag the m/z axis horizontally with left mouse button pressed. If you 
prefer using keyboard, use Left, Right, PageUp, PageDown, Home and End keys.

➡ To scale intensity axis:
Scroll the mouse wheel while holding Shift key or drag the intensity axis vertically with right mouse 
button pressed.

➡ To scale intensity axis automatically to fit current spectrum range:
Press  button from the bottom toolbar, or choose View → Autoscale Intensity from the main 
menu.

➡ To show full mass range:
Double-click on the m/z axis.

➡ To show full intensity range:
Double-click on the intensity axis.

➡ To show full spectrum:
Double-click anywhere in the spectrum.

View Options

There are different view options available for Spectrum Viewer. Those commonly used are available 
directly from the bottom toolbar, others can be accessed via the application main menu View.

show or hide gel view
show or hide cursor tracker

autoscale intensity axis
normalize intensity axis

canvas properties
show or hide labels
show or hide labels ticks
show or hide notation marks

labels orientation

Bottom toolbar with the most common Spectrum Viewer options.

➡ To show or hide gridlines:
Choose View → Show/Hide Gridlines from the main menu.

➡ To show or hide legend:
Choose View → Show/Hide Legend from the main menu.

➡ To show or hide legend in gel view:
Choose View → Show/Hide Gel Legend from the main menu.

➡ To show or hide position bar:
Choose View → Show/Hide Position Bar from the main menu.

➡ To show or hide intensity bar:
Choose View → Show/Hide Intensity Bar from the main menu.

➡ To show or hide gel view:
Press  button from the bottom toolbar, or choose View → Show/Hide Gel from the main menu.
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➡ To show or hide cursor tracker:
Press  button from the bottom toolbar, or choose View → Show/Hide Cursor Tracker from the 
main menu.

➡ To show or hide labels:
Press  button from the bottom toolbar, or choose View → Show/Hide Labels from the main menu.

➡ To show or hide labels ticks:
Press  button from the bottom toolbar, or choose View → Show/Hide Labels Ticks from the main 
menu.

➡ To show or hide charge in labels:
Choose View → Show/Hide Labels Charge from the main menu.

➡ To show or hide solid background for labels:
Choose View → Show/Hide Labels Background from the main menu.

➡ To show or hide notation marks:
Press  button from the bottom toolbar, or choose View → Show/Hide Notation Marks from the 
main menu.

➡ To change labels orientation:
Press  button from the bottom toolbar, or choose View → Horizontal/Vertical Labels from the 
main menu.

➡ To prevent overlapping labels:
Choose View → Non-Overlapping Labels from the main menu.

➡ To show labels in all documents:
Choose View → Labels in All Documents from the main menu. Only labels from the selected 
document will be shown if this feature is disabled.

➡ To enable or disable data points:
Choose View → Show/Hide Data Points from the main menu. Data points are typically visible on 
detailed zoom only.

➡ To enable intensity autoscale:
Press  button from the bottom toolbar, or choose View → Autoscale Intensity from the main 
menu.

➡ To enable intensity normalization:
Press  button from the bottom toolbar, choose View → Normalize Intensity from the main menu.

➡ To flip spectrum vertically:
Right-click on the document title in Documents Panel and choose Flip Spectrum.

➡ To offset spectrum intensity:
Right-click on the document title in Documents Panel and choose Offset Spectrum, or choose View 
→ Offset Spectrum from the main menu to show up offset dialog. Set Intensity offset and press 
Offset button.

➡ To clear spectrum offset:
Right-click on the document title and choose Clear Offset. Choose View → Clear Offsets from the 
main menu to clear offset for all documents.

Please note that normalization and spectrum offset are just a visualization tools and no data are 
changed.
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Canvas Properties dialog.

➡ To set m/z precision (number of digits):
Press  button from the bottom toolbar, or choose View → Canvas Properties from the main menu 
to show up Canvas Properties dialog and move the m/z precision slider. This settings is used for all 
occurrences of mass throughout the application.

➡ To set intensity precision (number of digits):
Press  button from the bottom toolbar, or choose View → Canvas Properties from the main menu 
to show up Canvas Properties dialog and move the Intensity precision slider. This settings is used for 
all occurrences of intensity throughout the application.

➡ To set gel height:
Press  button from the bottom toolbar, or choose View → Canvas Properties from the main menu 
to show up Canvas Properties dialog and move the Gel height slider.

➡ To set position and intensity bars height:
Press  button from the bottom toolbar, or choose View → Canvas Properties from the main menu 
to show up Canvas Properties dialog and move the Bars height slider.

➡ To set axis and legend font size:
Press  button from the bottom toolbar, or choose View → Canvas Properties from the main menu 
to show up Canvas Properties dialog and move the Canvas font size slider.

➡ To set label font size:
Press  button from the bottom toolbar, or choose View → Canvas Properties from the main menu 
to show up Canvas Properties dialog and move the Label font size slider.

Spectrum Tools

There are several mouse tools available for Spectrum Viewer such as Label Peak, Label Point, Delete 
Labels, Measure Distances and Offset Spectrum.

delete labels
measure distances

offset spectrumtools properties
label peak

label point

Bottom toolbar with Spectrum Viewer tools.
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Tools Properties dialog.

➡ To label peak:
Press  button from the bottom toolbar and select desired peak in the spectrum. Only the most 
intense peak in the selection will be labeled. See Data Processing chapter for more information.

➡ To label point:
Press  button from the bottom toolbar and click at desired point in the spectrum. Small cross mark 
tracks the spectrum until you release the mouse button.

➡ To delete labels:
Press  button from the bottom toolbar and select area where the labels should be deleted. Only 
those peaks/labels where its m/z and intensity values fall into the selected area will be deleted.

➡ To set peak picking height:
Press  button from the bottom toolbar to show up Tools Properties dialog and move the Picking 
height slider. See Data Processing chapter for more information.

➡ To calculate baseline level from peak vicinity rather then from entire spectrum:
Press  button from the bottom toolbar to show up Tools Properties dialog and check Adaptive 
threshold checkbox. See Data Processing chapter for more information.

➡ To automatically set labeled peak as monoisotopic:
Press  button from the bottom toolbar to show up Tools Properties dialog and check Set as 
monoisotopic checkbox.

➡ To measure distances in spectrum:
Press  button from the bottom toolbar and drag mouse in the spectrum with left mouse button 
pressed. Distance shows in the bottom toolbar and next to the cursor if Cursor Tracker is enabled.

➡ To offset spectrum intensity:
Press  button from the bottom toolbar and drag mouse in the spectrum with left mouse button 
pressed. Distance shows in the bottom toolbar and next to the cursor if Cursor Tracker is enabled. 
Current spectrum will be shifted after releasing the mouse button. Choose View → Offset Spectrum 
from the main menu to set spectrum offset manually.

Please note that spectrum offset is just a visualization tool and no real data are changed.

Please note that spectrum offset cannot be applied when normalized view is turned on.

5.6. Peaklist Panel

Peaklist Panel provides a table of all labeled peaks in selected document. For each peak, its m/z, 
corrected intensity (real intensity - baseline),  relative intensity, charge, signal to noise ratio, baseline 
intensity, fwhm and resolution are shown. From this panel, any peak can be added, annotated, edited or 
removed. A simple peak editor can be easily used to create your own peak list manually.
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m/z
full width at half maximum

resolution

baseline intensity
signal to noise ratio

intensity (measured-baseline)
relative intensity (to spectrum basepeak)

charge

add peak
delete peaks

annotate selected peak
show or hide peak editor

number of peaks in current peak list

Peaklist Panel with peak editor enabled.

➡ To manually add new peak:
Press  button from the bottom toolbar to show and clear peak editor, fill-up the peak parameters 
and press Add button.

➡ To edit peak parameters:
Press  button from the bottom toolbar to show peak editor and click on the peak. Edit peak 
parameters and press Replace button.

➡ To copy peak with different parameters:
Press  button from the bottom toolbar to show peak editor and click on the peak. Change peak 
parameters and press Add button.

➡ To delete peaks:
Select the peaks you want to delete and press Command+Backspace or Delete,  or press  button 
from the bottom toolbar and choose Delete Selected. You can use Delete Labels tool in Spectrum 
Viewer as well.

➡ To delete peaks by threshold:
Press  button from the bottom toolbar and choose Delete by Threshold to show up threshold 
dialog. Set Minimal value and Threshold type and press Delete button. Another way is to sort peak 
list by specific value, selecting and deleting unwanted peaks.

➡ To delete all peaks:
Press  button from the bottom toolbar and choose Delete All.

➡ To annotate peak:
Double-click the peak or press  button in the bottom toolbar to show up annotation dialog and 
type your annotation.

➡ To highlight peak in spectrum viewer:
Click on the peak and spectrum moves to the m/z value. Small red arrow shows up on m/z axis of 
the spectrum. Current zoom range remains the same.
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➡ To copy peaks into clipboard:
Select the peaks you want to copy,  press Command+C (Ctrl+C on MS Windows and Linux) and 
column selection dialog shows up. Select the columns you’d like to copy and press Copy.

➡ To export peak list:
Press  button from the main toolbar,  or choose File → Export from the main menu to show up 
Export dialog, and select Export Peaklist Data  tool. See Export chapter for more information.

Please note that “a.i.” value in the peak editor represents absolute peak intensity without any 
baseline correction, while corrected intensity is shown in the peak list table.
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6. Document Basics
6.1. Supported Formats

mMass supports several mass spectrometry formats. Popular XML-based formats like mzData (http://
www.psidev.info), mzXML (http://tools.proteomecenter.org) and mzML  (http://www.psidev.info),  which 
are open source and well documented are fully supported. Mass spectra and peak list data can also be 
imported from an ASCII file consisting of two columns (m/z and intensity pairs) separated by a tab,  space, 
comma or semicolon.

Since it is often impossible to obtain the manufacturer's description of their native file formats,  they are 
not currently supported. However, if you have a Bruker’s CompassXport tool installed on your computer 
it is automatically used to convert and open a raw data from all Bruker’s instruments.  This tool is 
available for free at www.bdal.de,  unfortunately, for MS Windows platform only. In mMass’s preferences 
you can specify whether mzData, mzXML or mzML  format will be used for conversion and whether 
profile spectrum or peak list only will be extracted. By default, converted file is not deleted after 
successful import but this can be changed in mMass’s preferences.

mMass is so-called a “single spectrum editor” therefore experiments such as LC-MS runs cannot be fully 
analyzed by mMass.  However, it is possible to open any selected scan from such runs to analyze it 
separately. Sure, it does not make sense for many LC-MS experiments but it can be useful in many cases.

6.2. Open Document

➡ To open document:
Drag the document file into mMass’s main window or choose File → Open from the main menu.

➡ To open selected scan from LC-MS run:
Drag the document file into mMass’s main window or choose File → Open from the main menu. If 
document contains more scans, Select Scan dialog shows up. Select scan(s) you’d like to open and 
press Open button. Total ion chromatogram and base peak chromatogram is available if 
corresponding parameters are found in the data.

Select Scan dialog.
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➡ To open spectrum from Bruker’s instruments:
Drag the spectrum folder into mMass’s main window or choose File → Open from the main menu 
and locate the analysis.baf,  analysis.yep or fid file. You need to have CompassXport tool installed. 
This function is currently available for MS Windows platform only.

For ASCII XY and some mzXML  documents mMass is unable to determine whether the document 
contains spectrum points or just centroides of peaks and chooses spectrum as default. If this decision 
isn’t correct you can swap the data between line spectrum and peak list by choosing Processing → 
Swap Data from the main menu.

Please note that CompassXport tool does not allow non-ascii characters in a document path.

6.3. Blank Document

One of the unique features of mMass is the ability to make a blank document and manually create peak 
list. This feature is particularly useful in those cases where raw spectrum is unavailable, and user has only 
a spectrum image or printed list of labelled peaks. Such is often the situation in laboratories that do not 
have their own instruments and have to send their samples to other laboratories. This feature gives such 
laboratories the chance to analyze the data themselves. Once the peak list is prepared, all interpretation 
tools can be used. See Peaklist Panel chapter for more information about peak list editing.

Blank documents can also be used for protein digest or peptide fragmentation simulations or to make a 
personal database of sequences which can be easily imported into any document.

➡ To open blank document:
Press  button from the bottom toolbar and select New Document or choose File → New from the 
main menu.

6.4. Save Document

To retain all the information related to analysis such as protein sequence or user’s annotations mMass has 
its own document format to store the data (mSD format). This format is XML-based to be easily 
processed by other software.

➡ To save document:
Select the document in Documents Panel and choose File → Save from the main menu.

6.5. Export

Export tools.
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➡ To export spectrum image:
Press  button from the main toolbar or choose File → Export from the main menu to show up 
Export dialog,  and select Export Spectrum Image  tool. Specify export parameters and press 
Export button.

➡ To export spectrum points:
Press  button from the main toolbar or choose File → Export from the main menu to show up 
Export dialog, and select Export Spectrum Data  tool. Specify export parameters and press Export 
button.

➡ To export peak list:
Press  button from the main toolbar or choose File → Export from the main menu to show up 
Export dialog and select Export Peaklist Data  tool. Specify export parameters and press Export 
button.

On MacOS X and Linux platform you can use native support for PDF creation to export spectrum 
into vector format. From the main menu choose File → Print and select PDF. On MS Windows you 
need to have some PDF convertor installed first.

To export spectrum images for monitor only,  use 72 dpi. To export large spectrum images for 
printing or publications use larger resolution to thicken-up the lines and fonts. Is is often the case 
that for smaller images, font size became too big. Use Canvas Properties dialog and set the font size.

6.6. Print Spectrum

➡ To print spectrum:
Choose File → Print Spectrum from the main menu and current Spectrum Viewer contents will be 
printed.

6.7. Document Info

Document Info panel provides some information about selected document and place to write your own 
description of the sample, analysis and results. It is generally good idea to fill up this information if you 
want to share the analysis with other people.

Document Summary

In the Document Summary part of Document Info panel you can specify document Title,  Operator’s name, 
Contact and Institution, used Instrument and measurement Date. You can save current values as a presets 
to use it later again.

Document Summary.
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➡ To show document summary:
Press  button from the main toolbar or choose File → Document Info from the main menu to show 
up Document Info panel. Then press  button from the panel toolbar.

➡ To save current values as presets:
Write the information you’d like to save as presets. Press  button from the panel toolbar and 
choose Save as Presets. In the dialog write presets name and press Save button.

➡ To use saved presets:
Press  button from the panel toolbar and choose any of your presets from the pup-up menu.

➡ To delete saved presets:
Choose Libraries → Presets from the main menu to show up Presets Library editor. Choose the 
presets you’d like to delete and press Delete button.

➡ To rename saved presets:
Choose Libraries → Presets from the main menu to show up Presets Library editor. Choose the 
presets you’d like to rename, type the new name and press Rename button.

Spectrum Info

In the Spectrum Info part of Document Info panel you can specify Scan ID, Retention time, MS level 
Precursor m/z, Precursor charge and Polarity. In addition, number of spectrum points and total number  
of peaks in peak list are shown.

Spectrum Info.

➡ To show spectrum info:
Press  button from the main toolbar or choose File → Document Info from the main menu to show 
up Document Info panel. Then press  button from the panel toolbar.

Please note that if you are importing a document from mzML format, Scan ID value does not 
correspond to the real scan number. Unfortunately, it is not possible to get the scan number value 
from mzML due to its non-uniform formatting. For both, mzXML and mzData formats, Scan ID 
corresponds to particular scan number.

Analysis Notes

Analysis Notes provides a place to type you personal notes about sample preparation, sample analysis and 
interpretation results. These information will be also shown in analysis report. See Analysis Report 
chapter for more information.
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Analysis Notes.

➡ To show analysis notes:
Press  button from the main toolbar or choose File → Document Info from the main menu to show 
up Document Info panel. Then press  button from the panel toolbar.

6.8. Analysis Report

Analysis report can be generated from selected document and all available information such as document 
info, current Spectrum Viewer contents,  user’s notes and annotations, sequence, modifications and 
matches will be included. This report is generated in HTML format and automatically shows up in your 
web browser.

Analysis report.

➡ To make analysis report:
Press  button from the main toolbar or choose File → Analysis Report from the main menu. Report 
shows up in your web browser.

➡ To sort data in report tables:
Click on appropriate column header in the report. Please note that this feature needs to have 
JavaScript enabled in your web browser.

It is generally good practice to write your analysis notes and results into document using Document 
Info tool prior to report generation. See Document Info chapter for more information.

On MacOS X and Linux platform you can use native support for PDF creation to make PDF report. 
When the report shows up in your web browser choose File → Print and select PDF. On MS 
Windows you need to have some PDF convertor installed first.
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7. Data Processing
mMass offers number of common data processing functions such as mathematical operations, data crop, 
baseline correction, smoothing, peak picking, charging and deisotoping. In order to avoid permanent 
changing of parameters and speed up the processing of data from different instruments you can define 
your own processing presets and use it frequently. For math operations, smoothing and baseline 
correction a preview is available and recommended to use before modifying your data.  Your last 
processing step can be undone.

➡ To open data processing tool:
On Mac OS X press  button from the main toolbar. Separate buttons for different processing tools 
are available on other platforms. All the tools can be reached via Processing menu as well.

➡ To undo last processing step:
From the main menu choose Processing → Undo.

➡ To save current values as presets:
Press  button from the panel toolbar and choose Save as Presets. In the dialog type the presets 
name and press Save button.

➡ To use saved presets:
Press  button from the panel toolbar and choose any of your presets from the pup-up menu.

➡ To delete saved presets:
Choose Libraries → Presets from the main menu to show up Presets Library editor. Choose the 
presets you’d like to delete and press Delete button.

➡ To rename saved presets:
Choose Libraries → Presets from the main menu to show up Presets Library editor. Choose the 
presets you’d like to rename, type the new name and press Rename button.

Please note that every presets contains parameters from all the processing tools. If you load any 
presets, parameters for all the tools will be changed. This is especially important for Peak Picking 
tool where parameters from other panels are used (Smoothing and Deisotoping).

7.1. Math Operations

Simple math operations are available to add or subtract two documents, or to multiply current document 
by a specified factor. If you combine two documents containing spectrum points,  operation is applied on 
the spectrum points only and document peak list (if any) is erased. Only the spectrum points can be 
subtracted. Multiplying is applied on both, spectrum points and peak list as well.

Math Operations tool.

• Operation - math operation to be applied.

• Spectrum B - spectrum to be added or subtracted from current document.

• Multiplier - multiplying factor.
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➡ To open math operation tool:
On Mac OS X press  button from the main toolbar, then press  button from the panel toolbar. 
On other platforms press  button from the main toolbar. You can choose Processing → Math 
Operations from the main menu as well.

➡ To add spectrum to selected document:
Select a document in the Documents Panel. In the Math Operations tool select “A+B” and the 
document to be added (Spectrum B). Press Preview button to see the results as a temporary (red) 
spectrum or Apply button to apply operation on selected document.

➡ To subtract spectrum from selected document:
Select a document in the Documents Panel.  In the Math Operations tool select “A-B” and the 
document to be subtracted (Spectrum B). Press Preview button to see the results as a temporary (red) 
spectrum or Apply button to apply operation on selected document.

➡ To multiply selected document:
Select a document in the Documents Panel. In the Math Operations tool select “A*X”  and specify 
multiplier factor (Multiplier X). Press Preview button to see the results as a temporary (red) spectrum 
or Apply button to apply operation on selected document.

Please note that Preview is not available for peak list processing.

To be able to sum-up or subtract two spectra, both must have the same x-raster. Unfortunately, this is 
not often the case,  therefore additional points must be added and resulted spectrum can easily 
became very huge and processing time extremely long! Since x-raster is mostly changed by different 
calibrations, it is generally good idea to apply this processing prior to any re-calibration step.

Please note that while the spectrum and peak list are changed by math operations, all the user’s 
annotations and sequence matches remains the same and especially the intensity value can therefore 
be inaccurate. It is up to your decision if you prefer to retain or to remove such items. (It is generally 
good idea to apply this processing function prior to any data interpretation.)

7.2. Crop

This function simply discards all the spectrum data points, labeled peaks, annotations and sequence 
matches which are out of the m/z range specified by Low mass and High mass parameters.

Crop tool.

• Low mass - data below this limit will be removed.

• High mass - data above this limit will be removed.

➡ To open crop tool:
On Mac OS X press  button from the main toolbar, then press  button from the panel toolbar. 
On other platforms press  button from the main toolbar. You can choose Processing → Crop from 
the main menu as well.

➡ To crop data:
Using Low mass and High mass values specify the m/z range to keep and press Apply button.
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Using Crop tool to remove “matrix area” from MALDI-TOF mass spectra can significantly reduce 
number of spectrum data points and speed up other processing.

7.3. Baseline Correction

Especially for MALDI-TOF mass spectra of proteins a strong baseline distortion is common problem 
which needs to be corrected quite often. Using Baseline Correction tool, this processing step can be done 
very easily. Baseline is calculated from the spectrum noise as a median of all data points minus noise 
width (median of absolute deviations). Using Precision slider, baseline can be composed from 1 to 100 
segments to trace spectrum shape precisely. In addition, you can specify Relative offset to move baseline 
down a bit. Smooth baseline to eliminate local extremes.  After setting all the parameters you can see a 
preview prior to applying baseline correction to your data.

Baseline Correction tool.

• Precision - number of baseline segments (1 = straight line).

• Relative offset - baseline intensity shift.

• Smooth baseline - applies smoothing to baseline.

➡ To open baseline correction tool:
On Mac OS X press  button from the main toolbar, then press  button from the panel toolbar. 
On other platforms press  button from the main toolbar. You can choose Processing → Smooth 
Spectrum from the main menu as well.

➡ To preview corrected data:
Specify all the parameters and press Preview button. A temporary (red) corrected spectrum appears 
in Spectrum Viewer.

➡ To subtract baseline from data:
Specify all the parameters and press Apply button.

Please note that calculated baseline is shows in Spectrum Viewer while moving Precision or Relative 
offset slider. This feature can be very helpful to set baseline precisely.

Please note that current peak list will be removed after applying baseline correction.

Please note that while the spectrum and peak list are changed by baseline correction, all the user’s 
annotations and sequence matches remains the same and especially the intensity value is therefore 
inaccurate. It is up to your decision if you prefer to retain or to remove such items. (It is generally 
good idea to apply this processing function prior to any data interpretation.)
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7.4. Smoothing

You can use this function to smooth the noise which distorts peak shape. There are two different 
smoothing Methods available - Moving Average and Savitzky-Golay.  In general, Moving Average is much 
faster but causes intensity loss for sharp peaks. This method should be preferentially used to smooth high-
mass spectra where peaks are broader. On the other hand, Savitzky-Golay filter is very slow but intensity 
loss is lower. This method should be preferentially used to smooth low-mass spectra where peaks are 
sharp. After setting all the parameters you can see a preview prior to processing your data.

Smoothing tool.

• Method - smoothing algorithm.

• Window size - smoothing window.

• Cycles - number of smoothing repetitions.

➡ To open smooth tool:
On Mac OS X press  button from the main toolbar, then press  button from the panel toolbar. 
On other platforms press  button from the main toolbar. You can choose Processing → Smooth 
Spectrum from the main menu as well.

➡ To preview smoothed data:
Specify all the parameters and press Preview button. A temporary (red) smoothed spectrum appears 
in Spectrum Viewer.

➡ To smooth data:
Specify all the parameters and press Apply button.

For Moving Average method the Window size value should be about 1/3 of the peak width and 1/2 
for Savitzky-Golay method.

Always check the intensity loss for different peaks along the entire mass range. Use smaller Window 
size if the intensity loss is too strong.

Please note that at least 2 and 4 data points within the smoothing window are needed for Moving 
Average and Savitzky-Golay method respectively. No smoothing is applied if Window size is too 
narrow.

Please note that current peak list will be removed after applying smoothing.

Please note that while the spectrum and peak list are changed by smoothing, all the user’s 
annotations and sequence matches remains the same and especially the intensity value is therefore 
inaccurate. It is up to your decision if you prefer to retain or to remove such items. (It is generally 
good idea to apply this processing function prior to any data interpretation.)
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7.5. Peak Picking

As mentioned earlier in Spectrum Viewer chapter, there is a specific tool to label peaks manually. 
However, this could be very annoying especially for data-rich spectra like those from FTICR MS or 
Orbitrap. Fortunately, an algorithm is incorporated into mMass to facilitate automatic peak picking. There 
are couple of basic steps in the peak picking algorithm:

• Pre-smoothing - if enabled, raw spectrum data are pre-smoothed to eliminate peak noise.

• Searching for local maxima - local maxima are temporarily labeled as potential peaks.

• Filtering by intensity threshold - peaks bellow user intensity threshold are being removed.

• Centroides calculation - peaks centroides are calculated and unresolved peaks are grouped together.

• Filtering by intensity threshold - peaks bellow user intensity threshold are being removed.

• Removing shoulder peaks - if enabled, “shoulder peaks” for FTMS data are being removed.

• Deisotoping - if enabled, deisotoping is applied to remove isotopes and calculate charges.

To get relevant intensities, for each peak its baseline is calculated. For a flat spectrum with constant noise 
along entire mass range a global noise level is used as the baseline for all peaks. This approach is very 
fast but generally not applicable for spectra with uneven baseline. In that cases, peak baselines can be 
calculated separately for each peak using the noise level from its surroundings using Adaptive threshold. 
This approach is slower but can be essential for protein mass spectra.

Peak Picking tool.

• S/N threshold - peaks bellow the signal to noise threshold will not be labeled.

• Abs. intensity threshold - peaks bellow the absolute intensity (peak intensity - baseline) threshold 
will not be labeled.

• Rel. intensity threshold - peaks bellow the relative intensity threshold will not be labeled.

• Adaptive threshold - each peak baseline will be calculated from its surroundings.

• Picking height - picking height for centroides.

• Apply smoothing - data will be smoothed prior to peak picking using current smoothing settings. See 
Smoothing chapter for more information.

• Apply deisotoping - peak isotopes will be removed and charge calculated using current deisotoping 
settings. See Deisotoping chapter for more information.

• Remove shoulder peaks - small surrounding peaks called “shoulder peaks” occurring in FTMS data 
will be removed.

➡ To open peak picking tool:
On Mac OS X press  button from the main toolbar, then press  button from the panel toolbar. 
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On other platforms press  button from the main toolbar. You can choose Processing → Peak 
Picking from the main menu as well.

➡ To label peaks:
Specify all the parameters and press Apply button.

Use pre-smoothing for MALDI-TOF data of any kind.

If pre-smoothing is enabled, don’t forget to check intensity loss for different peaks along the 
spectrum.

Smoothing significantly decreases number of local maxima, therefore speeds up further processing.

Using Adaptive threshold without pre-smoothing can sometimes be very slow.

If smoothing or deisotoping is enabled, don’t forget to check their settings in corresponding panels.

Please note that while the peak list is changed, all the user’s annotations and sequence matches 
remains the same and the m/z and intensity values are therefore inaccurate. It is up to your decision 
if you prefer to retain or to remove such items. (It is generally good idea to apply this processing 
function prior to any data interpretation.)

7.6. Deisotoping

The main purpose of this tool is to remove unwanted peak isotopes after peak picking. However, in order 
to find the isotopes a peak charge needs to be calculated, therefore this tool can be used for charge 
determination as well.

Starting from specified Maximum charge, for every peak its isotopes are searched using corresponding 
isotopic mass shift (1.00287/abs(z)) ± Isotope mass tolerance. If at least one isotope is found, parent peak 
is set as the monoisotopic with current charge state. If no isotope is found, current charge state is 
decreased (abs(z) - 1) and search cycle starts again for the same peak.

Because of possible peak overlaps, theoretical isotopic pattern needs to be taken into account. Intensity of 
every isotope is compared with its theoretical value. If the intensity is matching theoretical value 
± Isotope intensity tolerance, corresponding isotope is discarded from any subsequent search cycle. If the 
difference is over tolerance,  corresponding isotope will be used as possible parent (monoisotopic) peak in 
subsequent search cycle. Since mMass is mostly used for proteomic data interpretation, the averagine 
(C4.9384 N1.3577 O1.4773 S0.0417 H7.7583) is used to calculate theoretical isotopic patterns.

Deisotoping tool.
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• Maximum charge - maximum charge state to be searched.

• Isotope mass tolerance - tolerance for mass difference between adjacent isotopes.

• Isotope intensity tolerance - tolerance for intensity check between theoretical and measured isotope.

• Remove isotopes - all identified isotopes will be removed after processing.

• Remove unknown - all unknown peaks will be removed after processing.

➡ To open deisotoping tool:
On Mac OS X press  button from the main toolbar, then press  button from the panel toolbar. 
On other platforms press  button from the main toolbar. You can choose Processing → 
Deisotoping from the main menu as well.

➡ To deisotope peaks:
Specify all the parameters and press Apply button.

➡ To apply deisotoping automatically after peak picking:
In Peak Picking tool enable Apply deisotoping.

➡ To edit peak charge:
Press  in the Peaklist Panel bottom toolbar to show peak editor and click on the peak in the list. 
Set the new charge and press Replace button.

➡ To manually set peak as monoisotopic:
Press  in the Peaklist Panel bottom toolbar to show peak editor and click on the peak in the list. 
Check monoisotopic checkbox and press Replace button.

Please note the relationship between Maximum charge and Isotope mass tolerance. Isotope mass 
tolerance must be lower than 1.00287×(1/(z-1) - 1/z) to successfully distinguish z and z-1 charge.

Please note that the combination of averagine intensity distribution and higher Isotope intensity 
tolerance is generally applicable to wide range of organic compounds but can be very problematic if 
atoms like Cl, Fe, Hg, Pt etc. are incorporated.

7.7. Utilities

Normalize Data

To compare data between two different instruments it is sometimes necessary to normalize the data to a 
same intensity level.

➡ To normalize data:
Choose Processing → Normalize Data from the main menu.

Swap Data

For ASCII XY  and some mzXML documents mMass is unable to determine whether document contains 
line spectrum points or just centroides of peaks and chooses line spectrum as default.  If this decision isn’t 
correct you can swap the data between line spectrum and peak list.

➡ To swap data between spectrum and peak list:
Choose Processing → Swap Data from the main menu.
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8. Calibration
In order to re-calibrate you data mMass enables two principal approaches - standard calibration and 
statistical calibration. In the case of standard calibration any reference list must be selected first and 
reference values must be assigned to measured peaks. Reference values are assigned automatically using 
Tolerance value. You can use either Linear or Quadratic fitting to calculate calibration constants. In 
general, linear fitting is much safer if you want to re-calibrate an m/z range outside of your assigned 
references. Always see a calibration plot before recalculating your data.

Statistical calibration, sometimes called “self-calibration” is a special method for peptide mass spectra 
only. It does not need any external reference points since it is based on the fact that monoisotopic masses 
of peptides are distributed in a very regular way. Decimal fraction of the peptide mass can be calculated 
with sufficient accuracy just by multiplying their integral part by factor 1.00048. For this method, every 
peak above 700 m/z limit is recalculated and used as reference mass.

It is sometimes good to use other known peaks as internal calibration standards. Once you have the 
theoretical masses defined within your annotations or sequence matches, you can use them to re-calibrate 
your data. Please be careful while using this feature!

Calibration tool.

Calibration Error Plot.

➡ To show calibration tool:
Press  button from the main toolbar or choose Processing → Calibration from the main menu.

➡ To show error plot:
Press  button from the panel toolbar.

mMass User’s Guide

© 2010 Martin Strohalm  Page 39



➡ To assign reference masses:
Specify Tolerance value and Units and press Assign button.

➡ To exclude assigned reference from calculation:
Double-click on the reference in the list. Corresponding line turns grey and italic.

➡ To highlight reference mass in spectrum viewer:
Click on the reference in the list and spectrum moves to theoretical m/z value. Small red arrow 
shows up on m/z axis of the spectrum. Current zoom range remains the same.

➡ To use statistical calibration:
Check Statistical only checkbox.  Reference masses and calibration constants are automatically 
calculated from the current peak list.

➡ To define new reference list:
Choose Libraries → Calibration Masses from the main menu to show up Calibration Masses Library 
editor. See Libraries chapter for more information.

➡ To re-calibrate data by user annotations:
Right-click on any single annotation or the annotations root in Documents Panel and select Calibrate 
by Annotations. All the user annotations will be send to Calibration panel. Please note that only 
those annotations with specified theoretical m/z value can be used.

➡ To re-calibrate data by sequence matches:
Right-click on any single match or sequence title in Documents Panel and select Calibrate by 
Matches. All the matches will be send to Calibration panel.

➡ To apply same calibration to multiple documents:
Once the calibration is calculated you can apply it to multiple documents. Simply select another 
document in Documents Panel and press Apply Recent button.

Always check Error plot to see whether the calibration is correct.

In general, use Linear fitting if assigned references do not cover entire m/z range you’d like to 
calibrate.

Single-point calibration can be used for linear fitting.

User annotations and sequence matches are re-calibrated as well.

Please note that at least 3 reference mass points are needed for quadratic fitting.

Please note that the calibration is calculated using absolute m/z errors. Therefore shown calibration 
curve cannot be liner if you have “ppm” units selected, even if linear model is used.

Please note that statistical calibration can be used for peptides only! Any non-peptide contamination 
or modification could have disturbing effect to the calibration and should be discarded from 
calculations.
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9. Mass Calculator
Mass Calculator provides a tools for calculation of molecular masses of compounds,  generation of ion 
series and isotopic pattern simulation. Molecular formula can be typed manually or can be sent from 
various mMass’s tools such as Protein Digest,  Peptide Fragmentation etc. Theoretical isotopic profile can 
be easily overlaid with measured data or stored as regular document.

➡ To show mass calculator:
Press  button from the main toolbar or choose Tools → Mass Calculator from the main menu.

9.1. Formula Syntax

All known elements and their isotopes are defined within mMass’s library and can be used to define any 
compound. Use the following syntax rules to specify compound formula:

• Use common syntax to type simple formula: C16H32O2.

• Use parenthesis “()” to define groups: CH3(CH2)14COOH

• Use negative “-” values to remove atoms: CH3(CH2)14COOH(NaH-1)

• Use braces “{}” to define specific isotope of the element: C{13}16H32O2

Please note that using negative values for groups such as C16H32O2(OH)-1 does not work.

9.2. Compound Summary

Compound Summary panel provides a fast preview of the compound defined in Formula field. 
Composition, Monoisotopic and Average masses are shown.

Compound Summary.

➡ To show compound summary:
Press  button from the main toolbar or choose Tools → Mass Calculator from the main menu to 
show up Mass Calculator panel. Then press  button from the panel toolbar and write your 
compound into Formula field.

9.3. Ion Series

Using Ion Series panel you can see all the ions for the compound defined in Formula field. 
Corresponding monoisotopic and average masses are calculated with respect to polarity settings. By 
default, a proton is used as a “charging agent” but you can specify your own formula or “e” for radical 
ions.
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Ion Series.

➡ To show ion series:
Press  button from the main toolbar or choose Tools → Mass Calculator from the main menu to 
show up Mass Calculator panel. Then press  button from the panel toolbar and type your 
compound into Formula field. Ions are generated automatically.

➡ To copy ion series into clipboard:
Click into the ions list and press Command+C (Ctrl+C on MS Windows and Linux).

9.4. Isotopic Pattern

Isotopic Pattern panel provides a simple tool for generating theoretical isotopic pattern from compound 
formula. Isotopes are calculated and grouped together with respect to specified Peak width. For each 
isotope, Gaussian-shape peak is modeled and final profile is calculated as a sum of all the peaks.

Theoretical isotopic profile can be overlaid with measured data and positioned precisely using FWHM, 
Intensity, Baseline and m/z Shift. You can save theoretical profile as regular document as well.

Isotopic Pattern within Mass Calculator tool.

Collapsed version of Isotopic Pattern panel.
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➡ To show isotopic pattern:
Press  button from the main toolbar or choose Tools → Mass Calculator from the main menu to 
show up Mass Calculator panel. Then press  button from the panel toolbar and type your 
compound into Formula field.

➡ To change the ion type for current isotopic patter:
Press  button from the panel toolbar and select desired ion type in the list.

➡ To overlay isotopic pattern with measured data:
Press  button from the panel toolbar and select desired ion type in the list. Theoretical pattern is 
then overlaid with measured data. Set Intensity, Baseline and Shift values to position the pattern 
precisely.

➡ To save current isotopic pattern as regular document:
Press Save button from the panel toolbar.

➡ To collapse pattern panel:
Press the small triangle on the left side of the panel toolbar.

Use the same spectrum manipulation conventions in isotopic pattern window as in the main 
Spectrum Viewer.

On Mac OS X you can change pattern parameters using a mouse scroll as well.

Use collapsed panel while overlaying theoretical profile and acquired data. This provides you more 
space to look at your data but all the positioning parameters are still available.

Please note that when overlaying theoretical profile and acquired data, offset and flipping is applied 
automatically according to selected document.
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10.Periodic Table of Elements
Periodic Table of Elements provides some basic information about the elements.  Different groups can be 
highlighted and element name, mass and isotopic pattern can be shown. For each element its detailed 
information can be seen on Wikipedia (en.wikipedia.org/wiki/Periodic_table) or The Photographic 
Periodic Table of the Elements (www.periodictable.com) using direct links.

Periodic Table of Elements.

➡ To show periodic table:
Choose Tools → Periodic Table from the main menu.

➡ To highlight group of elements:
Select the group name from the Highlight combo box.

➡ To see element name and mass:
Press the element button.

➡ To see isotopic pattern of element:
Select the element in the table and press Isotopes button. Element pattern will be shown in Mass 
Calculator tool.

➡ To see detailed information about element:
Select the element in the table and press Wikipedia button. Corresponding wiki page shows up in 
your web browser.

➡ To see element photos:
Select the element in the table and press Photos button. Corresponding photo page shows up in your 
web browser.
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11.Sequence Tools
mMass provides an internal Sequence Editor,  which can be used to make any protein or peptide sequence 
available for other tools. Any modification can be applied either as fixed or variable. Protein Digest tool 
can be used to generate a list of peptides resulting from in silico enzymatic or chemical digestion of 
specified protein sequence. Similarly, Peptide Fragmentation tool generates a list of common peptide 
fragments. In both cases,  all possible combinations of variable modifications are calculated and results 
can be easily compared with measured data. In addition, sequence can be searched for a peptide mass by 
Mass Search tool to identify any non-specific cleavages.

11.1. Sequence Editor

Internal Sequence Editor provides a tool to define protein or peptide sequence to be available for other 
tools. Sequence can be manually typed, pasted from clipboard or imported from any mMass or FASTA 
document. Every input is checked automatically to contain only amino acids defined in mMass’s library. 
Some basic information about the sequence are shown in the panel toolbar and theoretical isotopic pattern 
can be generated as well. If any modification is set, modified amino acids are shown in red.

Sequence Editor.

➡ To add new sequence:
Press  button from the Documents Panel bottom toolbar and select New Sequence or choose 
Sequence → New from the main menu. Sequence Editor shows up. Type your sequence manually or 
use copy/paste.

➡ To import sequence:
Choose Sequence → Import from the main menu and select your sequence file. If more than one 
sequence are available in the file, a selection dialog shows up. Select one or more sequence and 
press Import button. mMass and FASTA documents are currently supported.

➡ To edit sequence:
Double-click on the sequence title in Documents Panel and Sequence Editor shows up.

➡ To delete sequence:
Click on the sequence title in Documents Panel and press Command+Backspace or Delete, or press 

 button from the Documents Panel bottom toolbar and choose Delete Sequence.

➡ To generate isotopic pattern from a whole sequence:
In Sequence Editor press Pattern button.

If a sequence is pasted from the clipboard all white spaces and numbers are removed automatically. 
This can be very useful if you copy/paste a sequence from web sites.
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If you are using some sequences frequently, save them into mMass document as a sequence library.

Please note that only valid sequences are show in the import dialog and can be imported.

Please note that calculated sequence mass includes all  fixed and variable modifications.

11.2. Modifications

In Sequence Modifications panel any post-translational modification can be set to a single amino acid or 
to selected type. Beside a position, for each modification you can specify whether it should be Fixed or 
Variable and all possible variants are then calculated in the sequence related tools. In order to avoid 
permanent assignment of the same modification set you can define your own presets and use it frequently.

Sequence Modifications.

• Show specific modifications only - show modifications specific for selected amino acid.

• Position - amino acid type and position.

• Modification - modification name and type.

➡ To add modification:
Press  button from the Sequence panel toolbar to show up Sequence Modifications. Select amino 
acid type, position, modification and modification type and press Add button.

➡ To remove modification:
Press  button from the Sequence panel toolbar to show up Sequence Modifications. Select  desired 
modification in the list and press Remove button.

➡ To edit modification:
Choose Libraries → Modifications from the main menu to show up Modifications Library editor.  See 
Libraries chapter for more information.

➡ To define new modification:
Choose Libraries → Modifications from the main menu to show up Modifications Library editor.  See 
Libraries chapter for more information.

➡ To save current global modifications as presets:
Press  button from the panel toolbar and choose Save as Presets. In the dialog type the presets 
name and press Save button.

➡ To use saved presets:
Press  button from the panel toolbar and choose any of your presets from the pup-up menu.
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➡ To delete saved presets:
Choose Libraries → Presets from the main menu to show up Presets Library editor. Choose the 
presets you’d like to delete and press Delete button.

➡ To rename saved presets:
Choose Libraries → Presets from the main menu to show up Presets Library editor. Choose the 
presets you’d like to rename, type the new name and press Rename button.

By default, only specific modifications for selected amino acid are shown, however, all available 
modifications can be enabled by unchecking Show specific modifications only checkbox.

Please note that multiple modifications on a single residue are not allowed.

Please note that only global modifications can be stored in presets.

11.3. Protein Digest

Many experiments,  involving detection of modifications, protein validation etc., apply the specific 
enzymatic digestion of a protein with a known sequence. Protein Digest panel provides a tool which can 
be used to generate a list of peptides resulting from in silico digestion of a sequence. Masses of these 
peptides can then be compared with current peak list within a specified tolerance to see any matches. In 
addition, theoretical isotopic patterns can be generated and overlaid with the data to validate matches.

Protein Digest tool.

• Mass - mass type to be used for calculations.

• Max charge - maximum charge to be calculated.

• Enzyme - enzyme to be used to simulate digestion.

• Miscl. - maximum number of enzyme miss cleavages.

• Mass range - m/z range for peptides to be calculated.

• Ignore mods - ignore modifications in cleavage site.

• Cov. - matched / theoretical sequence coverage.

➡ To digest protein:
Double-click on the sequence title in Documents Panel to show up Sequence tools and press  
button for Protein Digest tool. Specify all the parameters and press Digest button.
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➡ To highlight peptide mass in spectrum viewer:
Click on the peptide and spectrum moves to theoretical m/z value. Small red arrow shows up on m/z 
axis of the spectrum. Current zoom range remains the same.

➡ To show isotopic pattern of peptide:
Double-click on the peptide to show up Mass Calculator panel. Peptide formula appears in Formula 
field and corresponding ion type is selected. See Mass Calculator chapter for more information.

➡ To match peptides to peak list:
Generate theoretical peptides and press Match button in the panel toolbar to show up Match Peptides 
panel.  Matched peptides shows green and bold in the list.  See Data Matching chapter for more 
information.

➡ To annotate peaks by matched peptides:
Press Annotate button in the panel toolbar. All matches show up in Documents Panel under current 
sequence.

➡ To copy peptide sequence into clipboard:
Right-click on any peptide and choose Copy Selected Sequence from pop-up menu.

➡ To copy peptides into clipboard:
Click into the list and press Command+C (Ctrl+C on MS Windows and Linux) or use pop-up menu.

➡ To see matched/unmatched peptides only:
Right-click into the list and select view option from pop-up menu.

All variants are calculated for peptides with variable modifications.

Use theoretical sequence coverage to select the right enzyme for particular protein and mass range.

11.4. Peptide Fragmentation

Different types of fragmentation techniques can be used for the validation of a peptide sequence, as well 
as for the detection, localization and characterization of post-translational modifications. For these types 
of experiments, common fragments of a peptide sequence can be generated in silico using Peptide 
Fragmentation tool. Depending on a fragmentation technique used, different fragments can be generated. 
Some of the peptide fragments are theoretical only and can be filtered using Filter check box. Such 
fragments are shown in grey and italic when filtering is disabled.

Peptide Fragmentation tool.
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• Mass - mass type to be used for calculations.

• Max charge - maximum charge to be calculated.

• Ions - common fragment types to be calculated.

• Loss - common losses to be calculated.

• Internal - calculate internal fragments.

• N-ladder - calculate N-ladder fragments.

• C-ladder - calculate C-ladder fragments.

• Filter - filter nonsense fragments.

➡ To fragment peptide:
Double-click on the sequence title in Documents Panel to show up Sequence tools and press  
button for Peptide Fragmentation tool. Specify all the parameters and press Fragment button.

➡ To highlight fragment mass in spectrum viewer:
Click on the fragment and spectrum moves to theoretical m/z value.  Small red arrow shows up on m/
z axis of the spectrum. Current zoom range remains the same.

➡ To show isotopic pattern of fragment:
Double-click on the fragment to show up Mass Calculator panel. Fragment formula appears in 
Formula field and corresponding ion type is selected.  See Mass Calculator chapter for more 
information.

➡ To match fragments to peak list:
Generate theoretical fragments and press Match button in the panel toolbar to show up Match 
Fragments panel. Matched fragments shows green and bold in the list. See Data Matching chapter 
for more information.

➡ To annotate peaks by matched fragments:
Press Annotate button in the panel toolbar. All matches show up in Documents Panel under current 
sequence.

➡ To copy fragments into clipboard:
Click into the list and press Command+C (Ctrl+C on MS Windows and Linux) or use pop-up menu.

➡ To see matched/unmatched fragments only:
Right-click into the list and select view option from pop-up menu.

11.5. Data Matching

Both, theoretical peptides and fragments lists can be compared with peak list of current document by 
pressing Match button in corresponding tool.  If some of the peptides or fragments are matched 
successfully you can use them for data recalibration.

Match tool.

mMass User’s Guide

© 2010 Martin Strohalm  Page 49



Match summary.

• Tolerance - mass tolerance for data matching.

• Da, ppm - units for tolerance value.

• Ignore charge - ignore peak charge while data matching.

➡ To match peptides to peak list:
Generate theoretical peptides in Protein Digest tool and press Match button in the panel toolbar to 
show up Match Peptides panel. Specify the parameters and press Match button. Matched peptides 
shows green and bold in the peptides list.

➡ To match fragments to peak list:
Generate theoretical fragments in Peptide Fragmentation tool and press Match button in the panel 
toolbar to show up Match Fragments panel. Specify the parameters and press Match button. Matched 
fragments shows in green and bold in the fragments list.

➡ To ignore peak charge and use only m/z value while data matching:
Check Ignore charge checkbox.

➡ To re-calibrate data using matches:
Press Calibrate button in the panel toolbar to send matched items into Calibration tool. See 
Calibration chapter for more information. Please be se careful while using this feature!

Use the same spectrum manipulation conventions in the error plot as in the main Spectrum Viewer.

11.6. Mass Search

Using sequence Mass Search tool you can search a sequence for any peptide of specified m/z. This tool 
can be very useful for identification of the peaks resulting from non-specific cleavage of a protein.

Mass Search tool.

• Mass - peptide mass to be searched.
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• Mo, Av - mass type to be searched.

• Max charge - maximum charge to be calculated for peptides.

• Endings by - peptide “caps” (e.g. H and OH).

• Tolerance - mass tolerance for searching.

• Da, ppm - units for tolerance value.

➡ To search sequence:
Double-click on the sequence title in Documents Panel to show up Sequence tools and press  
button for Mass Search tool.  Specify all the parameters and press Search button. List of matched 
peptides will be shown.

➡ To highlight peptide mass in spectrum viewer:
Click on the peptide and spectrum moves to theoretical m/z value. Small red arrow shows up on m/z 
axis of the spectrum. Current zoom range remains the same.

➡ To show isotopic pattern of peptide:
Double-click on the peptide to show up Mass Calculator panel. Peptide formula appears in Formula 
field and corresponding ion type is selected. See Mass Calculator chapter for more information.

➡ To copy peptide sequence into clipboard:
Right-click on any peptide and choose Copy Selected Sequence from pop-up menu.

➡ To copy peptides into clipboard:
Click into the list and press Command+C (Ctrl+C on MS Windows and Linux) or use pop-up menu.
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12.Compounds Search
Using Compounds Search tool you can search for any user-specified compound or even a list of 
compounds in a peak list. Every compound is specified in mMass’s library as molecular formula, title and 
description, therefore both monoisotopic or average masses can be search with any charge. In addition 
common adducts can be searched automatically as well. All the matched peaks can be annotated and then 
shown or printed within analysis report.

Compounds Search tool.

• Compounds - compounds list to be searched.

• Formula - compound formula to be searched.

• Mass - mass type to be searched.

• Max charge - maximum charge to be calculated.

• M* - calculate radical ions.

• Adducts - type of adduct to be searched.

➡ To search for list of compounds:
Press  button from the main toolbar or choose Tools → Compounds Search from the main menu 
and select  tool in the panel toolbar. Select Compounds list name, set the parameters and press 
Generate button. Then press Match button to show up Match Compounds tool.

➡ To search for specified formula:
Press  button from the main toolbar or choose Tools → Compounds Search from the main menu 
and select  tool in the panel toolbar. Type compound Formula,  set the parameters and press 
Generate button. Then press Match button to show up Match Compounds tool. See Mass Calculator 
chapter for more information about formula syntax.

➡ To highlight compound mass in spectrum viewer:
Click on the compound and spectrum moves to theoretical m/z value. Small red arrow shows up on 
m/z axis of the spectrum. Current zoom range remains the same.

➡ To show isotopic pattern of compound:
Double-click on the compound to show up Mass Calculator panel. Compound formula appears in 
Formula field and corresponding ion type is selected automatically. See Mass Calculator chapter for 
more information.

➡ To copy compounds into clipboard:
Click into the list and press Command+C (Ctrl+C on MS Windows and Linux).

mMass User’s Guide

© 2010 Martin Strohalm  Page 52



➡ To see matched/unmatched compounds only:
Right-click into the list and select view option from pop-up menu.

➡ To define a new list of compounds:
Choose Libraries → Compounds from the main menu to show up Compounds Library editor.  See 
Libraries chapter for more information.

➡ To match compounds to peak list:
Generate theoretical compounds and press Match button in the panel toolbar to show up Match 
Compounds panel. Matched compounds shows in green and bold.

Compounds match tool.

Compounds match summary.

• Tolerance - mass tolerance for data matching.

• Da, ppm - units for tolerance value.

• Ignore charge - ignore peak charge while data matching.

➡ To annotate peaks by matched compounds:
Press Annotate button in panel toolbar. All matches show up in Documents Panel under 
Annotations.

➡ To ignore peak charge while data matching:
Check Ignore charge checkbox.

➡ To re-calibrate data using matches:
Press Calibrate button in the panel toolbar to send matched items into Calibration tool. See 
Calibration chapter for more information. Please be se careful while using this feature!

Use the same spectrum manipulation conventions in the error plot as in the main Spectrum Viewer.

See match summary panel for more information about current match.
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13.Peak Differences
Interpretation of mass spectra typically involves a seemingly never-ending check of the differences 
between all peaks in a spectrum. However, Peak Differences tool is able to simply generate a table of all 
the differences between the peaks in the peak list. This table can then be used to automatically compare, 
within a specified tolerance,  each difference with the respective masses of all amino acids, calculated 
dipeptides or specified m/z value. Peak Differences tool therefore provides a useful utility for de novo 
peptide sequencing or PTM search.

matches for selected differencetable of differencespeak list

Peak Differences tool.

• Difference - user defined m/z difference to searched.

• Amino acids - all available amino acids will be searched.

• Dipeptides - all calculated dipeptides will be searched.

• Mass - mass type to be used for amino acids and dipeptides calculation.

• Tolerance - mass tolerance for searching.

➡ To show peak differences tool:
Press  button from the main toolbar or choose Tools → Peak Differences from the main menu.

➡ To search:
Specify all the parameters and press Search button from the panel toolbar. Click on any highlighted 
differences to see corresponding matches.

If the specified mass is matched, corresponding difference turns green. If at least one amino acid is 
matched, corresponding difference turns dark blue. If at least one dipeptide is matched, 
corresponding difference turns light blue.

Please note that the differences which does not make sense for current mass range (for specified 
Difference, Amino acids and Dipeptides) are not shown for better readability.
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14.Compare Peak Lists
Similarly as the Peak Differences tool, the Compare Peak Lists tool can easily be utilized to compare 
peak lists or annotations between multiple documents.  Using this tool, one of the most typical and 
annoying manual task can be automatically performed within a few clicks.  Once the tool is shown, all of 
the opened documents are loaded and marked by its own spectrum color and can be compared within the 
specified mass tolerance. For each peak identified in a different document, corresponding document color 
is shown next to the m/z value. By selecting any m/z value in the peak lists table, all the matched peaks 
are shown followed by error and intensity ratios (a - selected peak, b - matched peak).

Compare Peak Lists tool.

• Compare - data type to be compared.

• Tolerance - mass tolerance for comparison.

• Da, ppm - units for tolerance value.

• Ignore charge - ignore peak charge while comparing peaks.

➡ To show compare peak lists tool:
Press  button from the main toolbar or choose Tools → Compare Peak Lists from the main menu.

➡ To compare:
Specify all the parameters and press Compare button from the panel toolbar. Click on any m/z value 
in the peak lists table to see corresponding matches.

➡ To remove peak list temporarily:
Disable document by clicking the corresponding document bullet in the main Documents Panel.

➡ To copy tables into clipboard:
Click into the table you’d like to copy and press Command+C (Ctrl+C on MS Windows and Linux).
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15.Mascot Search
mMass provides an interface that allows data to be directly sent to the main tools available on Mascot 
website (http://www.matrixscience.com); Peptide Mass Fingerprint, Sequence Query and MS/MS Ion 
Search. When Search button is pressed, temporary HTML page is generated containing all the parameters 
and using JavaScript,  the page is automatically sent to selected server. Please see the Mascot website for 
more information about the tools and the form fields.

Peptide Mass Fingerprint search tool.

➡ To show peptide mass fingerprint tool:
Press  button from the main toolbar to show Mascot tools and press  button from the panel 
toolbar or choose Tools → Mascot Peptide Mass Fingerprint from the main menu.

➡ To show MS/MS ion search tool:
Press  button from the main toolbar to show Mascot tools and press  button from the panel 
toolbar or choose Tools → Mascot MS/MS Ion Search from the main menu.

➡ To show sequence query tool:
Press  button from the main toolbar to show Mascot tools and press  button from the panel 
toolbar or choose Tools → Mascot Sequence Query from the main menu.

➡ To change server:
Select the Server in the panel toolbar.

➡ To send data to server:
Specify all the parameters and press Send button in the panel toolbar. HTML page will be generated 
and sent to specified server. Results show up in your default web browser.

➡ To define new server:
Choose Libraries → Mascot Servers from the main menu to show up Mascot Servers Library editor. 
See Libraries chapter for more information.
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➡ To specify peak list or query:
Press  from the panel toolbar and type your query manually or use Peak list selection.

Query / Peak List.

See http://www.matrixscience.com website for more information about Mascot tools and form 
parameters.

Please note that while changing server, most of the form fields changed as well. Check if the form is 
filled correctly.
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16.ProFound Search
mMass provides an interface that allows data to be directly sent to ProFound search tool available on a 
website of Professor Brian T. Chait group (http://prowl.rockefeller.edu). When Search button is pressed, 
temporary HTML page is generated containing all the parameters and using JavaScript,  the page is 
automatically sent to ProFound server. Please see the ProFound website for more information about the 
tool and the form fields.

ProFound search tool.

➡ To show ProFound tool:
Press  button from the main toolbar or choose Tools → ProFound from the main menu.

➡ To send data to server:
Specify all the parameters and press Send button in the panel toolbar. HTML page will be generated 
and sent to ProFound server. Results show up in your default web browser.

➡ To specify peak list:
Press  from the panel toolbar and use Peak list selection.

See http://prowl.rockefeller.edu website for more information about ProFound tool and form 
parameters.
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17.Protein Prospector Search
mMass provides a simplified interface that allows data to be directly sent to the main tools available on 
Protein Prospector website (http://prospector.ucsf.edu); MS-Fit and MS-Tag.  When Search button is 
pressed, temporary HTML page is generated containing all the parameters and using JavaScript,  the page 
is automatically sent to Protein Prospector server. Please see the Protein Prospector website for more 
information about the tools and the form fields.

MS-Fit search tool.

➡ To show MS-Fit tool:
Choose Tools → Protein Prospector MS-Fit from the main menu.

➡ To show MS-Tag tool:
Choose Tools → Protein Prospector MS-Tag from the main menu.

➡ To send data to server:
Specify all the parameters and press Send button in the panel toolbar. HTML page will be generated 
and sent to Protein Prospector server. Results show up in your default web browser.

➡ To specify peak list:
Press  from the panel toolbar and use Peak list selection.

See http://prospector.ucsf.edu website for more information about ProteinProspector tools and form 
parameters.
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18.Libraries
All mMass’s libraries and configuration files are located within a single configuration folder having 
different locations, depending on your platform. On Mac OS X, all configuration files can be found under 
“~/Library/Application Support/mMass/”. On MS Windows and Linux systems, all configuration files 
can be found under “configs” folder, located directly under the mMass’s main folder.  All files are in 
XML-based formats and can be easily edited manually, however, it is strongly recommended to use 
dedicated mMass’s tools.

18.1. Modifications

Modifications Library editor.

• Name - unique modification name.

• Description - brief description.

• Amino specifity - amino acids which can be modified.

• Term specifity - sequence terminus which can be modified.

• Gain formula - formula to be added to a sequence.

• Loss formula - formula to be removed from a sequence. 

• Mo. mass - resulting monoisotopic mass.

• Av. mass - resulting average mass.

➡ To show modification library editor:
Choose Libraries → Modifications from the main menu.

➡ To add modification:
Open Modifications Library editor, specify all the modification parameters and press Add button.

➡ To edit modification:
Open Modifications Library editor, select the modification you’d like to edit, change the parameters 
and press Add button. If the Name remains the same you will be asked to Replace modification 
definition.
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➡ To rename modification:
Open Modifications Library editor, select the modification you’d like to rename, change the Name 
and press Add button. New modification will be added and the old one can be deleted.

➡ To delete modification:
Open Modifications Library editor, select the modification you’d like to delete and press Delete 
button. It is not possible to delete modification which is used in one of the opened documents.

See Mass Calculator chapter for more information about formula syntax.

Monoisotopic and average masses are calculated automatically as you type the formula.

If you open a document with undefined modification this modification is added into your library 
automatically, however, the Amino specifity is set to ACDEFGHIKLMNPQRSTVWY.

Please note that the modification name must be unique for each modification.

18.2. Enzymes

Enzymes Library editor

• Name - unique enzyme name.

• Expression - enzyme regular expression.

• C-term formula - formula to be added at new C-terminus.

• N-term formula - formula to be added at new N-terminus.

• Allow modification before cut - allow modifications before cleavage site.

• Allow modification after cut - allow modifications after cleavage site.

➡ To show enzymes library editor:
Choose Libraries → Enzymes from the main menu.

➡ To add enzyme:
Open Enzymes Library editor, specify all the enzyme parameters and press Add button.
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➡ To edit enzyme:
Open Enzymes Library editor, select the enzyme you’d like to edit, change the parameters and press 
Add button. If the Name remains the same you will be asked to Replace enzyme definition.

➡ To rename enzyme:
Open Enzymes Library editor, select the enzyme you’d like to rename, change the Name and press 
Add button. New enzyme will be added and the old one can be deleted.

➡ To delete enzyme:
Open Enzymes Library editor, select the enzyme you’d like to delete and press Delete button.

The enzyme expression uses regular expression syntax where both, amino acids before and after 
cleavage must be defined. For example [KR][A-Z] for the Trypsin/P, where [KR] means that lysine 
or arginine must be before cleavage and [A-Z] means that any amino acid (i.e. character in the 
sequence) is allowed after cleavage. To block any amino acid use “^” like in the regular Trypsin 
[KR][^P].  See the http://docs.python.org/howto/regex.html#regex-howto for more information about 
regular expression syntax.

See Mass calculator chapter for more information about formula syntax.

Please note that the enzyme name must be unique for each enzyme.

18.3. Compounds

Compounds Library editor.

• Name - unique compound name.

• Description - brief description.

• Formula - compound formula

• Mo. mass - resulting monoisotopic mass.

• Av. mass - resulting average mass.
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➡ To show compounds library editor:
Choose Libraries → Compounds from the main menu.

➡ To import compounds lists:
Open Compounds Library editor and press Import button on top of the panel. Select your 
compounds library and press Open button. Select compounds lists you’d like to import and press 
Import button. See above for location of all the libraries on your system.

➡ To add new compounds list:
Open Compounds Library editor and press New button on top of the panel.  Type the name and press 
OK button.

➡ To rename compounds list:
Open Compounds Library editor,  select the list you’d like to rename and press Rename button on top 
of the panel. Type the name and press OK button.

➡ To delete compounds list:
Open Compounds Library editor,  select the list you’d like to delete and press Delete button on top of 
the panel.

➡ To add compound:
Open Compounds Library editor and select the list for the compound. Specify all the compound 
parameters and press Add button down on the panel.

➡ To edit compound:
Open Compounds Library editor and select the list containing the compound you’d like to edit. 
Change the compound parameters and press Add button down on the panel.

➡ To rename compounds:
Open Compounds Library editor and select the list containing the compound you’d like to rename. 
Change the Name and press Add button. New compound will be added and the old one can be 
deleted.

➡ To delete compound:
Open Compounds Library editor, select the list containing the compound you’d like to delete and 
press Delete button down on the panel.

See Mass Calculator chapter for more information about formula syntax.

Monoisotopic and average masses are calculated automatically as you type the formula.

Please note that the group name must be unique for each group.

Please note that the compound name must be unique for each compound.
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18.4. Calibration Masses

Calibration Masses editor.

• Description - calibrant name.

• Mass - reference mass.

➡ To show calibration masses library editor:
Choose Libraries → Calibration Masses from the main menu.

➡ To import reference lists:
Open Calibration Masses Library editor and press Import button on top of the panel.  Select your 
references library and press Open button. Select references lists you’d like to import and press 
Import button. See above for location of all the libraries on your system.

➡ To add new reference list:
Open Calibration Masses Library editor and press New button on top of the panel. Type the name 
and press OK button.

➡ To rename reference list:
Open Calibration Masses Library editor, select the list you’d like to rename and press Rename 
button on top of the panel. Type the name and press OK button.

➡ To delete reference list:
Open Calibration Masses Library editor,  select the list you’d like to delete and press Delete button 
on top of the panel. Type the name and press OK button.

➡ To add calibration mass:
Open Calibration Masses Library editor and select the list for the calibration mass. Specify all the 
calibration mass parameters and press Add button down on the panel.

➡ To edit calibration mass:
Open Calibration Masses Library editor and select the list containing the calibration mass you’d like 
to edit. Change the calibration mass parameters and press Add button down on the panel.

➡ To rename calibration mass:
Open Calibration Masses Library editor and select the list containing the calibration mass you’d like 
to rename. Change the Name and press Add button. New calibration mass will be added and the old 
one can be deleted.
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➡ To delete calibration mass:
Open Calibration Masses Library editor, select the list containing the calibration mass you’d like to 
delete and press Delete button down on the panel.

18.5. Mascot Servers

Mascot Servers Library editor.

• Title - server title.

• Host name - IP address or domain.

• Mascot path - path to the Mascot’s main folder (“/” or “/mascot/” etc.).

• Search - path to the main search script (relative to the Mascot’s main folder).

• Results - path to the results viewer script (relative to he Mascot’s main folder).

• Export - path to the results export script (relative to he Mascot’s main folder).

• Params - path to the form parameters values (relative to he Mascot’s main folder).

➡ To show mascot servers library editor:
Choose Libraries → Mascot Servers from the main menu.

➡ To add server:
Open Mascot Servers Library editor, specify all the server parameters and press Add button.

➡ To edit server:
Open Mascot Servers Library editor, select the server you’d like to edit, change the parameters and 
press Add button. If the Title remains the same you will be asked to Replace server definition.

➡ To rename server:
Open Mascot Servers Library editor, select the server you’d like to rename, change the Title and 
press Add button. New server will be added and the old one can be deleted.

➡ To delete server:
Open Mascot Servers Library editor, select the server you’d like to delete and press Delete button.
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18.6. Presets

Presets Library editor.

• Name - presets name.

• Category - presets category.

➡ To show presets library editor:
Choose Libraries → Presets from the main menu.

➡ To rename presets:
Open Presets Library editor, select the presets you’d like to rename, change the Name and press 
Rename button.

➡ To delete presets:
Open Presets Library editor, select the presets you’d like to delete and press Delete button.
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19.Appendix
19.1. Elements

Configuration file “elements.xml” contains all the elements available for formula definitions.

<?xml version="1.0" encoding="utf-8" ?>
<mspyElements version="1.0">
  <element symbol="Ac" name="Actinium" atomicNumber="89">
    <mass monoisotopic="227.027747" average="227.027747" />
    <isotopes>
      <isotope massNumber="227" mass="227.027747" abundance="1.0" />
    </isotopes>
  </element>
  <element symbol="Ag" name="Silver" atomicNumber="47">
    <mass monoisotopic="106.905093" average="107.868150697" />
    <isotopes>
      <isotope massNumber="107" mass="106.905093" abundance="0.51839" />
      <isotope massNumber="109" mass="108.904756" abundance="0.48161" />
    </isotopes>
  </element>
  <element symbol="Al" name="Aluminium" atomicNumber="13">
    <mass monoisotopic="26.98153844" average="26.98153844" />
    <isotopes>
      <isotope massNumber="27" mass="26.98153844" abundance="1.0" />
    </isotopes>
  </element>
  <element symbol="Am" name="Americium" atomicNumber="95">
    <mass monoisotopic="243.0613727" average="243.0613727" />
    <isotopes>
      <isotope massNumber="241" mass="241.0568229" abundance="0.0" />
      <isotope massNumber="243" mass="243.0613727" abundance="1.0" />
    </isotopes>
  </element>
  <element symbol="Ar" name="Argon" atomicNumber="18">
    <mass monoisotopic="39.962383123" average="39.9476767176" />
    <isotopes>
      <isotope massNumber="36" mass="35.96754628" abundance="0.003365" />
      <isotope massNumber="38" mass="37.9627322" abundance="0.000632" />
      <isotope massNumber="40" mass="39.962383123" abundance="0.996003" />
    </isotopes>
  </element>
  <element symbol="As" name="Arsenic" atomicNumber="33">
    <mass monoisotopic="74.9215964" average="74.9215964" />
    <isotopes>
      <isotope massNumber="75" mass="74.9215964" abundance="1.0" />
    </isotopes>
  </element>
  <element symbol="At" name="Astatine" atomicNumber="85">
    <mass monoisotopic="210.987481" average="210.987481" />
    <isotopes>
      <isotope massNumber="210" mass="209.987131" abundance="0.0" />
      <isotope massNumber="211" mass="210.987481" abundance="1.0" />
    </isotopes>
  </element>
  <element symbol="Au" name="Gold" atomicNumber="79">
    <mass monoisotopic="196.966552" average="196.966552" />
    <isotopes>
      <isotope massNumber="197" mass="196.966552" abundance="1.0" />
    </isotopes>
  </element>
  <element symbol="B" name="Boron" atomicNumber="5">
    <mass monoisotopic="11.0093055" average="10.8110281685" />
    <isotopes>
      <isotope massNumber="10" mass="10.012937" abundance="0.199" />
      <isotope massNumber="11" mass="11.0093055" abundance="0.801" />
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    </isotopes>
  </element>
  <element symbol="Ba" name="Barium" atomicNumber="56">
    <mass monoisotopic="137.905241" average="137.326885691" />
    <isotopes>
      <isotope massNumber="130" mass="129.90631" abundance="0.00106" />
      <isotope massNumber="132" mass="131.905056" abundance="0.00101" />
      <isotope massNumber="134" mass="133.904503" abundance="0.02417" />
      <isotope massNumber="135" mass="134.905683" abundance="0.06592" />
      <isotope massNumber="136" mass="135.90457" abundance="0.07854" />
      <isotope massNumber="137" mass="136.905821" abundance="0.11232" />
      <isotope massNumber="138" mass="137.905241" abundance="0.71698" />
    </isotopes>
  </element>
  <element symbol="Be" name="Beryllium" atomicNumber="4">
    <mass monoisotopic="9.0121821" average="9.0121821" />
    <isotopes>
      <isotope massNumber="9" mass="9.0121821" abundance="1.0" />
    </isotopes>
  </element>
  <element symbol="Bh" name="Bohrium" atomicNumber="107">
    <mass monoisotopic="264.12473" average="264.12473" />
    <isotopes>
      <isotope massNumber="264" mass="264.12473" abundance="1.0" />
    </isotopes>
  </element>
  <element symbol="Bi" name="Bismuth" atomicNumber="83">
    <mass monoisotopic="208.980383" average="208.980383" />
    <isotopes>
      <isotope massNumber="209" mass="208.980383" abundance="1.0" />
    </isotopes>
  </element>
  <element symbol="Bk" name="Berkelium" atomicNumber="97">
    <mass monoisotopic="247.070299" average="247.070299" />
    <isotopes>
      <isotope massNumber="247" mass="247.070299" abundance="1.0" />
      <isotope massNumber="249" mass="249.07498" abundance="0.0" />
    </isotopes>
  </element>
  <element symbol="Br" name="Bromine" atomicNumber="35">
    <mass monoisotopic="78.9183376" average="79.9035284215" />
    <isotopes>
      <isotope massNumber="79" mass="78.9183376" abundance="0.5069" />
      <isotope massNumber="81" mass="80.916291" abundance="0.4931" />
    </isotopes>
  </element>
  <element symbol="C" name="Carbon" atomicNumber="6">
    <mass monoisotopic="12.0" average="12.0107358968" />
    <isotopes>
      <isotope massNumber="12" mass="12.0" abundance="0.9893" />
      <isotope massNumber="13" mass="13.0033548378" abundance="0.0107" />
      <isotope massNumber="14" mass="14.003241988" abundance="0.0" />
    </isotopes>
  </element>
  <element symbol="Ca" name="Calcium" atomicNumber="20">
    <mass monoisotopic="39.9625912" average="40.0780228528" />
    <isotopes>
      <isotope massNumber="40" mass="39.9625912" abundance="0.96941" />
      <isotope massNumber="42" mass="41.9586183" abundance="0.00647" />
      <isotope massNumber="43" mass="42.9587668" abundance="0.00135" />
      <isotope massNumber="44" mass="43.9554811" abundance="0.02086" />
      <isotope massNumber="46" mass="45.9536928" abundance="4e-05" />
      <isotope massNumber="48" mass="47.952534" abundance="0.00187" />
    </isotopes>
  </element>
  <element symbol="Cd" name="Cadmium" atomicNumber="48">
    <mass monoisotopic="113.9033581" average="112.411552733" />
    <isotopes>
      <isotope massNumber="106" mass="105.906458" abundance="0.0125" />
      <isotope massNumber="108" mass="107.904183" abundance="0.0089" />
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      <isotope massNumber="110" mass="109.903006" abundance="0.1249" />
      <isotope massNumber="111" mass="110.904182" abundance="0.128" />
      <isotope massNumber="112" mass="111.9027572" abundance="0.2413" />
      <isotope massNumber="113" mass="112.9044009" abundance="0.1222" />
      <isotope massNumber="114" mass="113.9033581" abundance="0.2873" />
      <isotope massNumber="116" mass="115.904755" abundance="0.0749" />
    </isotopes>
  </element>
  <element symbol="Ce" name="Cerium" atomicNumber="58">
    <mass monoisotopic="139.905434" average="140.11572154" />
    <isotopes>
      <isotope massNumber="136" mass="135.90714" abundance="0.00185" />
      <isotope massNumber="138" mass="137.905986" abundance="0.00251" />
      <isotope massNumber="140" mass="139.905434" abundance="0.8845" />
      <isotope massNumber="142" mass="141.90924" abundance="0.11114" />
    </isotopes>
  </element>
  <element symbol="Cf" name="Californium" atomicNumber="98">
    <mass monoisotopic="251.07958" average="251.07958" />
    <isotopes>
      <isotope massNumber="249" mass="249.074847" abundance="0.0" />
      <isotope massNumber="250" mass="250.0764" abundance="0.0" />
      <isotope massNumber="251" mass="251.07958" abundance="1.0" />
      <isotope massNumber="252" mass="252.08162" abundance="0.0" />
    </isotopes>
  </element>
  <element symbol="Cl" name="Chlorine" atomicNumber="17">
    <mass monoisotopic="34.96885271" average="35.4525381934" />
    <isotopes>
      <isotope massNumber="35" mass="34.96885271" abundance="0.7578" />
      <isotope massNumber="37" mass="36.9659026" abundance="0.2422" />
    </isotopes>
  </element>
  <element symbol="Cm" name="Curium" atomicNumber="96">
    <mass monoisotopic="247.070347" average="247.070347" />
    <isotopes>
      <isotope massNumber="243" mass="243.0613822" abundance="0.0" />
      <isotope massNumber="244" mass="244.0627463" abundance="0.0" />
      <isotope massNumber="245" mass="245.0654856" abundance="0.0" />
      <isotope massNumber="246" mass="246.0672176" abundance="0.0" />
      <isotope massNumber="247" mass="247.070347" abundance="1.0" />
      <isotope massNumber="248" mass="248.072342" abundance="0.0" />
    </isotopes>
  </element>
  <element symbol="Co" name="Cobalt" atomicNumber="27">
    <mass monoisotopic="58.9332002" average="58.9332002" />
    <isotopes>
      <isotope massNumber="59" mass="58.9332002" abundance="1.0" />
    </isotopes>
  </element>
  <element symbol="Cr" name="Chromium" atomicNumber="24">
    <mass monoisotopic="51.9405119" average="51.9961375164" />
    <isotopes>
      <isotope massNumber="50" mass="49.9460496" abundance="0.04345" />
      <isotope massNumber="52" mass="51.9405119" abundance="0.83789" />
      <isotope massNumber="53" mass="52.9406538" abundance="0.09501" />
      <isotope massNumber="54" mass="53.9388849" abundance="0.02365" />
    </isotopes>
  </element>
  <element symbol="Cs" name="Caesium" atomicNumber="55">
    <mass monoisotopic="132.905447" average="132.905447" />
    <isotopes>
      <isotope massNumber="133" mass="132.905447" abundance="1.0" />
    </isotopes>
  </element>
  <element symbol="Cu" name="Copper" atomicNumber="29">
    <mass monoisotopic="62.9296011" average="63.5456438786" />
    <isotopes>
      <isotope massNumber="63" mass="62.9296011" abundance="0.6917" />
      <isotope massNumber="65" mass="64.9277937" abundance="0.3083" />
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    </isotopes>
  </element>
  <element symbol="Db" name="Dubnium" atomicNumber="105">
    <mass monoisotopic="262.11415" average="262.11415" />
    <isotopes>
      <isotope massNumber="262" mass="262.11415" abundance="1.0" />
    </isotopes>
  </element>
  <element symbol="Dy" name="Dysprosium" atomicNumber="66">
    <mass monoisotopic="163.929171" average="162.497030039" />
    <isotopes>
      <isotope massNumber="156" mass="155.924278" abundance="0.0006" />
      <isotope massNumber="158" mass="157.924405" abundance="0.001" />
      <isotope massNumber="160" mass="159.925194" abundance="0.0234" />
      <isotope massNumber="161" mass="160.92693" abundance="0.1891" />
      <isotope massNumber="162" mass="161.926795" abundance="0.2551" />
      <isotope massNumber="163" mass="162.928728" abundance="0.249" />
      <isotope massNumber="164" mass="163.929171" abundance="0.2818" />
    </isotopes>
  </element>
  <element symbol="Er" name="Erbium" atomicNumber="68">
    <mass monoisotopic="165.93029" average="167.256301073" />
    <isotopes>
      <isotope massNumber="162" mass="161.928775" abundance="0.0014" />
      <isotope massNumber="164" mass="163.929197" abundance="0.0161" />
      <isotope massNumber="166" mass="165.93029" abundance="0.3361" />
      <isotope massNumber="167" mass="166.932045" abundance="0.2293" />
      <isotope massNumber="168" mass="167.932368" abundance="0.2678" />
      <isotope massNumber="170" mass="169.93546" abundance="0.1493" />
    </isotopes>
  </element>
  <element symbol="Es" name="Einsteinium" atomicNumber="99">
    <mass monoisotopic="252.08297" average="252.08297" />
    <isotopes>
      <isotope massNumber="252" mass="252.08297" abundance="1.0" />
    </isotopes>
  </element>
  <element symbol="Eu" name="Europium" atomicNumber="63">
    <mass monoisotopic="152.921226" average="151.964366222" />
    <isotopes>
      <isotope massNumber="151" mass="150.919846" abundance="0.4781" />
      <isotope massNumber="153" mass="152.921226" abundance="0.5219" />
    </isotopes>
  </element>
  <element symbol="F" name="Fluorine" atomicNumber="9">
    <mass monoisotopic="18.9984032" average="18.9984032" />
    <isotopes>
      <isotope massNumber="19" mass="18.9984032" abundance="1.0" />
    </isotopes>
  </element>
  <element symbol="Fe" name="Iron" atomicNumber="26">
    <mass monoisotopic="55.9349421" average="55.845150209" />
    <isotopes>
      <isotope massNumber="54" mass="53.9396148" abundance="0.05845" />
      <isotope massNumber="56" mass="55.9349421" abundance="0.91754" />
      <isotope massNumber="57" mass="56.9353987" abundance="0.02119" />
      <isotope massNumber="58" mass="57.9332805" abundance="0.00282" />
    </isotopes>
  </element>
  <element symbol="Fm" name="Fermium" atomicNumber="100">
    <mass monoisotopic="257.095099" average="257.095099" />
    <isotopes>
      <isotope massNumber="257" mass="257.095099" abundance="1.0" />
    </isotopes>
  </element>
  <element symbol="Fr" name="Francium" atomicNumber="87">
    <mass monoisotopic="223.0197307" average="223.0197307" />
    <isotopes>
      <isotope massNumber="223" mass="223.0197307" abundance="1.0" />
    </isotopes>
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  </element>
  <element symbol="Ga" name="Gallium" atomicNumber="31">
    <mass monoisotopic="68.925581" average="69.7230715461" />
    <isotopes>
      <isotope massNumber="69" mass="68.925581" abundance="0.60108" />
      <isotope massNumber="71" mass="70.924705" abundance="0.39892" />
    </isotopes>
  </element>
  <element symbol="Gd" name="Gadolinium" atomicNumber="64">
    <mass monoisotopic="157.924101" average="157.252119251" />
    <isotopes>
      <isotope massNumber="152" mass="151.919788" abundance="0.002" />
      <isotope massNumber="154" mass="153.920862" abundance="0.0218" />
      <isotope massNumber="155" mass="154.922619" abundance="0.148" />
      <isotope massNumber="156" mass="155.92212" abundance="0.2047" />
      <isotope massNumber="157" mass="156.923957" abundance="0.1565" />
      <isotope massNumber="158" mass="157.924101" abundance="0.2484" />
      <isotope massNumber="160" mass="159.927051" abundance="0.2186" />
    </isotopes>
  </element>
  <element symbol="Ge" name="Germanium" atomicNumber="32">
    <mass monoisotopic="73.9211782" average="72.6127591769" />
    <isotopes>
      <isotope massNumber="70" mass="69.9242504" abundance="0.2084" />
      <isotope massNumber="72" mass="71.9220762" abundance="0.2754" />
      <isotope massNumber="73" mass="72.9234594" abundance="0.0773" />
      <isotope massNumber="74" mass="73.9211782" abundance="0.3628" />
      <isotope massNumber="76" mass="75.9214027" abundance="0.0761" />
    </isotopes>
  </element>
  <element symbol="H" name="Hydrogen" atomicNumber="1">
    <mass monoisotopic="1.0078250321" average="1.00794075393" />
    <isotopes>
      <isotope massNumber="1" mass="1.0078250321" abundance="0.999885" />
      <isotope massNumber="2" mass="2.014101778" abundance="0.000115" />
      <isotope massNumber="3" mass="3.0160492675" abundance="0.0" />
    </isotopes>
  </element>
  <element symbol="He" name="Helium" atomicNumber="2">
    <mass monoisotopic="4.0026032497" average="4.00260189809" />
    <isotopes>
      <isotope massNumber="3" mass="3.0160293097" abundance="1.37e-06" />
      <isotope massNumber="4" mass="4.0026032497" abundance="0.99999863" />
    </isotopes>
  </element>
  <element symbol="Hf" name="Hafnium" atomicNumber="72">
    <mass monoisotopic="179.9465488" average="178.484970787" />
    <isotopes>
      <isotope massNumber="174" mass="173.94004" abundance="0.0016" />
      <isotope massNumber="176" mass="175.9414018" abundance="0.0526" />
      <isotope massNumber="177" mass="176.94322" abundance="0.186" />
      <isotope massNumber="178" mass="177.9436977" abundance="0.2728" />
      <isotope massNumber="179" mass="178.9458151" abundance="0.1362" />
      <isotope massNumber="180" mass="179.9465488" abundance="0.3508" />
    </isotopes>
  </element>
  <element symbol="Hg" name="Mercury" atomicNumber="80">
    <mass monoisotopic="201.970626" average="200.599149363" />
    <isotopes>
      <isotope massNumber="196" mass="195.965815" abundance="0.0015" />
      <isotope massNumber="198" mass="197.966752" abundance="0.0997" />
      <isotope massNumber="199" mass="198.968262" abundance="0.1687" />
      <isotope massNumber="200" mass="199.968309" abundance="0.231" />
      <isotope massNumber="201" mass="200.970285" abundance="0.1318" />
      <isotope massNumber="202" mass="201.970626" abundance="0.2986" />
      <isotope massNumber="204" mass="203.973476" abundance="0.0687" />
    </isotopes>
  </element>
  <element symbol="Ho" name="Holmium" atomicNumber="67">
    <mass monoisotopic="164.930319" average="164.930319" />
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    <isotopes>
      <isotope massNumber="165" mass="164.930319" abundance="1.0" />
    </isotopes>
  </element>
  <element symbol="I" name="Iodine" atomicNumber="53">
    <mass monoisotopic="126.904468" average="126.904468" />
    <isotopes>
      <isotope massNumber="127" mass="126.904468" abundance="1.0" />
    </isotopes>
  </element>
  <element symbol="In" name="Indium" atomicNumber="49">
    <mass monoisotopic="114.903878" average="114.818085851" />
    <isotopes>
      <isotope massNumber="113" mass="112.904061" abundance="0.0429" />
      <isotope massNumber="115" mass="114.903878" abundance="0.9571" />
    </isotopes>
  </element>
  <element symbol="Ir" name="Iridium" atomicNumber="77">
    <mass monoisotopic="192.962924" average="192.216053791" />
    <isotopes>
      <isotope massNumber="191" mass="190.960591" abundance="0.373" />
      <isotope massNumber="193" mass="192.962924" abundance="0.627" />
    </isotopes>
  </element>
  <element symbol="K" name="Potassium" atomicNumber="19">
    <mass monoisotopic="38.9637069" average="39.0983013438" />
    <isotopes>
      <isotope massNumber="39" mass="38.9637069" abundance="0.932581" />
      <isotope massNumber="40" mass="39.96399867" abundance="0.000117" />
      <isotope massNumber="41" mass="40.96182597" abundance="0.067302" />
    </isotopes>
  </element>
  <element symbol="Kr" name="Krypton" atomicNumber="36">
    <mass monoisotopic="83.911507" average="83.7993250844" />
    <isotopes>
      <isotope massNumber="78" mass="77.920386" abundance="0.0035" />
      <isotope massNumber="80" mass="79.916378" abundance="0.0228" />
      <isotope massNumber="82" mass="81.9134846" abundance="0.1158" />
      <isotope massNumber="83" mass="82.914136" abundance="0.1149" />
      <isotope massNumber="84" mass="83.911507" abundance="0.57" />
      <isotope massNumber="86" mass="85.9106103" abundance="0.173" />
    </isotopes>
  </element>
  <element symbol="La" name="Lanthanum" atomicNumber="57">
    <mass monoisotopic="138.906348" average="138.905448683" />
    <isotopes>
      <isotope massNumber="138" mass="137.907107" abundance="0.0009" />
      <isotope massNumber="139" mass="138.906348" abundance="0.9991" />
    </isotopes>
  </element>
  <element symbol="Li" name="Lithium" atomicNumber="3">
    <mass monoisotopic="7.016004" average="6.94003707897" />
    <isotopes>
      <isotope massNumber="6" mass="6.0151223" abundance="0.0759" />
      <isotope massNumber="7" mass="7.016004" abundance="0.9241" />
    </isotopes>
  </element>
  <element symbol="Lr" name="Lawrencium" atomicNumber="103">
    <mass monoisotopic="262.10969" average="262.10969" />
    <isotopes>
      <isotope massNumber="262" mass="262.10969" abundance="1.0" />
    </isotopes>
  </element>
  <element symbol="Lu" name="Lutetium" atomicNumber="71">
    <mass monoisotopic="174.9407679" average="174.966717486" />
    <isotopes>
      <isotope massNumber="175" mass="174.9407679" abundance="0.9741" />
      <isotope massNumber="176" mass="175.9426824" abundance="0.0259" />
    </isotopes>
  </element>
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  <element symbol="Md" name="Mendelevium" atomicNumber="101">
    <mass monoisotopic="258.098425" average="258.098425" />
    <isotopes>
      <isotope massNumber="256" mass="256.09405" abundance="0.0" />
      <isotope massNumber="258" mass="258.098425" abundance="1.0" />
    </isotopes>
  </element>
  <element symbol="Mg" name="Magnesium" atomicNumber="12">
    <mass monoisotopic="23.9850419" average="24.3050517925" />
    <isotopes>
      <isotope massNumber="24" mass="23.9850419" abundance="0.7899" />
      <isotope massNumber="25" mass="24.98583702" abundance="0.1" />
      <isotope massNumber="26" mass="25.98259304" abundance="0.1101" />
    </isotopes>
  </element>
  <element symbol="Mn" name="Manganese" atomicNumber="25">
    <mass monoisotopic="54.9380496" average="54.9380496" />
    <isotopes>
      <isotope massNumber="55" mass="54.9380496" abundance="1.0" />
    </isotopes>
  </element>
  <element symbol="Mo" name="Molybdenum" atomicNumber="42">
    <mass monoisotopic="97.9054078" average="95.9312915571" />
    <isotopes>
      <isotope massNumber="100" mass="99.907477" abundance="0.0963" />
      <isotope massNumber="92" mass="91.90681" abundance="0.1484" />
      <isotope massNumber="94" mass="93.9050876" abundance="0.0925" />
      <isotope massNumber="95" mass="94.9058415" abundance="0.1592" />
      <isotope massNumber="96" mass="95.9046789" abundance="0.1668" />
      <isotope massNumber="97" mass="96.906021" abundance="0.0955" />
      <isotope massNumber="98" mass="97.9054078" abundance="0.2413" />
    </isotopes>
  </element>
  <element symbol="Mt" name="Meitnerium" atomicNumber="109">
    <mass monoisotopic="268.13882" average="268.13882" />
    <isotopes>
      <isotope massNumber="268" mass="268.13882" abundance="1.0" />
    </isotopes>
  </element>
  <element symbol="N" name="Nitrogen" atomicNumber="7">
    <mass monoisotopic="14.0030740052" average="14.0067430936" />
    <isotopes>
      <isotope massNumber="14" mass="14.0030740052" abundance="0.99632" />
      <isotope massNumber="15" mass="15.0001088984" abundance="0.00368" />
    </isotopes>
  </element>
  <element symbol="Na" name="Sodium" atomicNumber="11">
    <mass monoisotopic="22.98976967" average="22.98976967" />
    <isotopes>
      <isotope massNumber="23" mass="22.98976967" abundance="1.0" />
    </isotopes>
  </element>
  <element symbol="Nb" name="Niobium" atomicNumber="41">
    <mass monoisotopic="92.9063775" average="92.9063775" />
    <isotopes>
      <isotope massNumber="93" mass="92.9063775" abundance="1.0" />
    </isotopes>
  </element>
  <element symbol="Nd" name="Neodymium" atomicNumber="60">
    <mass monoisotopic="141.907719" average="144.236126978" />
    <isotopes>
      <isotope massNumber="142" mass="141.907719" abundance="0.272" />
      <isotope massNumber="143" mass="142.90981" abundance="0.122" />
      <isotope massNumber="144" mass="143.910083" abundance="0.238" />
      <isotope massNumber="145" mass="144.912569" abundance="0.083" />
      <isotope massNumber="146" mass="145.913112" abundance="0.172" />
      <isotope massNumber="148" mass="147.916889" abundance="0.057" />
      <isotope massNumber="150" mass="149.920887" abundance="0.056" />
    </isotopes>
  </element>
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  <element symbol="Ne" name="Neon" atomicNumber="10">
    <mass monoisotopic="19.9924401759" average="20.180046417" />
    <isotopes>
      <isotope massNumber="20" mass="19.9924401759" abundance="0.9048" />
      <isotope massNumber="21" mass="20.99384674" abundance="0.0027" />
      <isotope massNumber="22" mass="21.99138551" abundance="0.0925" />
    </isotopes>
  </element>
  <element symbol="Ni" name="Nickel" atomicNumber="28">
    <mass monoisotopic="57.9353479" average="58.6933562856" />
    <isotopes>
      <isotope massNumber="58" mass="57.9353479" abundance="0.680769" />
      <isotope massNumber="60" mass="59.9307906" abundance="0.262231" />
      <isotope massNumber="61" mass="60.9310604" abundance="0.011399" />
      <isotope massNumber="62" mass="61.9283488" abundance="0.036345" />
      <isotope massNumber="64" mass="63.9279696" abundance="0.009256" />
    </isotopes>
  </element>
  <element symbol="No" name="Nobelium" atomicNumber="102">
    <mass monoisotopic="259.10102" average="259.10102" />
    <isotopes>
      <isotope massNumber="259" mass="259.10102" abundance="1.0" />
    </isotopes>
  </element>
  <element symbol="Np" name="Neptunium" atomicNumber="93">
    <mass monoisotopic="237.0481673" average="237.0481673" />
    <isotopes>
      <isotope massNumber="237" mass="237.0481673" abundance="1.0" />
      <isotope massNumber="239" mass="239.0529314" abundance="0.0" />
    </isotopes>
  </element>
  <element symbol="O" name="Oxygen" atomicNumber="8">
    <mass monoisotopic="15.9949146221" average="15.9994049284" />
    <isotopes>
      <isotope massNumber="16" mass="15.9949146221" abundance="0.99757" />
      <isotope massNumber="17" mass="16.9991315" abundance="0.00038" />
      <isotope massNumber="18" mass="17.9991604" abundance="0.00205" />
    </isotopes>
  </element>
  <element symbol="Os" name="Osmium" atomicNumber="76">
    <mass monoisotopic="191.961479" average="190.224861062" />
    <isotopes>
      <isotope massNumber="184" mass="183.952491" abundance="0.0002" />
      <isotope massNumber="186" mass="185.953838" abundance="0.0159" />
      <isotope massNumber="187" mass="186.9557479" abundance="0.0196" />
      <isotope massNumber="188" mass="187.955836" abundance="0.1324" />
      <isotope massNumber="189" mass="188.9581449" abundance="0.1615" />
      <isotope massNumber="190" mass="189.958445" abundance="0.2626" />
      <isotope massNumber="192" mass="191.961479" abundance="0.4078" />
    </isotopes>
  </element>
  <element symbol="P" name="Phosphorus" atomicNumber="15">
    <mass monoisotopic="30.97376151" average="30.97376151" />
    <isotopes>
      <isotope massNumber="31" mass="30.97376151" abundance="1.0" />
    </isotopes>
  </element>
  <element symbol="Pa" name="Protactinium" atomicNumber="91">
    <mass monoisotopic="231.0358789" average="231.0358789" />
    <isotopes>
      <isotope massNumber="231" mass="231.0358789" abundance="1.0" />
    </isotopes>
  </element>
  <element symbol="Pb" name="Lead" atomicNumber="82">
    <mass monoisotopic="207.976636" average="207.21689158" />
    <isotopes>
      <isotope massNumber="204" mass="203.973029" abundance="0.014" />
      <isotope massNumber="206" mass="205.974449" abundance="0.241" />
      <isotope massNumber="207" mass="206.975881" abundance="0.221" />
      <isotope massNumber="208" mass="207.976636" abundance="0.524" />
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    </isotopes>
  </element>
  <element symbol="Pd" name="Palladium" atomicNumber="46">
    <mass monoisotopic="105.903483" average="106.415328028" />
    <isotopes>
      <isotope massNumber="102" mass="101.905608" abundance="0.0102" />
      <isotope massNumber="104" mass="103.904035" abundance="0.1114" />
      <isotope massNumber="105" mass="104.905084" abundance="0.2233" />
      <isotope massNumber="106" mass="105.903483" abundance="0.2733" />
      <isotope massNumber="108" mass="107.903894" abundance="0.2646" />
      <isotope massNumber="110" mass="109.905152" abundance="0.1172" />
    </isotopes>
  </element>
  <element symbol="Pm" name="Promethium" atomicNumber="61">
    <mass monoisotopic="144.912744" average="144.912744" />
    <isotopes>
      <isotope massNumber="145" mass="144.912744" abundance="1.0" />
      <isotope massNumber="147" mass="146.915134" abundance="0.0" />
    </isotopes>
  </element>
  <element symbol="Po" name="Polonium" atomicNumber="84">
    <mass monoisotopic="208.982416" average="208.982416" />
    <isotopes>
      <isotope massNumber="209" mass="208.982416" abundance="1.0" />
      <isotope massNumber="210" mass="209.982857" abundance="0.0" />
    </isotopes>
  </element>
  <element symbol="Pr" name="Praseodymium" atomicNumber="59">
    <mass monoisotopic="140.907648" average="140.907648" />
    <isotopes>
      <isotope massNumber="141" mass="140.907648" abundance="1.0" />
    </isotopes>
  </element>
  <element symbol="Pt" name="Platinum" atomicNumber="78">
    <mass monoisotopic="194.964774" average="195.077791315" />
    <isotopes>
      <isotope massNumber="190" mass="189.95993" abundance="0.00014" />
      <isotope massNumber="192" mass="191.961035" abundance="0.00782" />
      <isotope massNumber="194" mass="193.962664" abundance="0.32967" />
      <isotope massNumber="195" mass="194.964774" abundance="0.33832" />
      <isotope massNumber="196" mass="195.964935" abundance="0.25242" />
      <isotope massNumber="198" mass="197.967876" abundance="0.07163" />
    </isotopes>
  </element>
  <element symbol="Pu" name="Plutonium" atomicNumber="94">
    <mass monoisotopic="244.064198" average="244.064198" />
    <isotopes>
      <isotope massNumber="238" mass="238.0495534" abundance="0.0" />
      <isotope massNumber="239" mass="239.0521565" abundance="0.0" />
      <isotope massNumber="240" mass="240.0538075" abundance="0.0" />
      <isotope massNumber="241" mass="241.0568453" abundance="0.0" />
      <isotope massNumber="242" mass="242.0587368" abundance="0.0" />
      <isotope massNumber="244" mass="244.064198" abundance="1.0" />
    </isotopes>
  </element>
  <element symbol="Ra" name="Radium" atomicNumber="88">
    <mass monoisotopic="226.0254026" average="226.0254026" />
    <isotopes>
      <isotope massNumber="223" mass="223.018497" abundance="0.0" />
      <isotope massNumber="224" mass="224.020202" abundance="0.0" />
      <isotope massNumber="226" mass="226.0254026" abundance="1.0" />
      <isotope massNumber="228" mass="228.0310641" abundance="0.0" />
    </isotopes>
  </element>
  <element symbol="Rb" name="Rubidium" atomicNumber="37">
    <mass monoisotopic="84.9117893" average="85.4676641059" />
    <isotopes>
      <isotope massNumber="85" mass="84.9117893" abundance="0.7217" />
      <isotope massNumber="87" mass="86.9091835" abundance="0.2783" />
    </isotopes>
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  </element>
  <element symbol="Re" name="Rhenium" atomicNumber="75">
    <mass monoisotopic="186.9557508" average="186.206705433" />
    <isotopes>
      <isotope massNumber="185" mass="184.9529557" abundance="0.374" />
      <isotope massNumber="187" mass="186.9557508" abundance="0.626" />
    </isotopes>
  </element>
  <element symbol="Rf" name="Rutherfordium" atomicNumber="104">
    <mass monoisotopic="261.10875" average="261.10875" />
    <isotopes>
      <isotope massNumber="261" mass="261.10875" abundance="1.0" />
    </isotopes>
  </element>
  <element symbol="Rh" name="Rhodium" atomicNumber="45">
    <mass monoisotopic="102.905504" average="102.905504" />
    <isotopes>
      <isotope massNumber="103" mass="102.905504" abundance="1.0" />
    </isotopes>
  </element>
  <element symbol="Rn" name="Radon" atomicNumber="86">
    <mass monoisotopic="222.0175705" average="222.0175705" />
    <isotopes>
      <isotope massNumber="211" mass="210.990585" abundance="0.0" />
      <isotope massNumber="220" mass="220.0113841" abundance="0.0" />
      <isotope massNumber="222" mass="222.0175705" abundance="1.0" />
    </isotopes>
  </element>
  <element symbol="Ru" name="Ruthenium" atomicNumber="44">
    <mass monoisotopic="101.9043495" average="101.06494499" />
    <isotopes>
      <isotope massNumber="100" mass="99.9042197" abundance="0.126" />
      <isotope massNumber="101" mass="100.9055822" abundance="0.1706" />
      <isotope massNumber="102" mass="101.9043495" abundance="0.3155" />
      <isotope massNumber="104" mass="103.90543" abundance="0.1862" />
      <isotope massNumber="96" mass="95.907598" abundance="0.0554" />
      <isotope massNumber="98" mass="97.905287" abundance="0.0187" />
      <isotope massNumber="99" mass="98.9059393" abundance="0.1276" />
    </isotopes>
  </element>
  <element symbol="S" name="Sulfur" atomicNumber="16">
    <mass monoisotopic="31.97207069" average="32.0660846938" />
    <isotopes>
      <isotope massNumber="32" mass="31.97207069" abundance="0.9493" />
      <isotope massNumber="33" mass="32.9714585" abundance="0.0076" />
      <isotope massNumber="34" mass="33.96786683" abundance="0.0429" />
      <isotope massNumber="36" mass="35.96708088" abundance="0.0002" />
    </isotopes>
  </element>
  <element symbol="Sb" name="Antimony" atomicNumber="51">
    <mass monoisotopic="120.903818" average="121.759788176" />
    <isotopes>
      <isotope massNumber="121" mass="120.903818" abundance="0.5721" />
      <isotope massNumber="123" mass="122.9042157" abundance="0.4279" />
    </isotopes>
  </element>
  <element symbol="Sc" name="Scandium" atomicNumber="21">
    <mass monoisotopic="44.9559102" average="44.9559102" />
    <isotopes>
      <isotope massNumber="45" mass="44.9559102" abundance="1.0" />
    </isotopes>
  </element>
  <element symbol="Se" name="Selenium" atomicNumber="34">
    <mass monoisotopic="79.9165218" average="78.95938873" />
    <isotopes>
      <isotope massNumber="74" mass="73.9224766" abundance="0.0089" />
      <isotope massNumber="76" mass="75.9192141" abundance="0.0937" />
      <isotope massNumber="77" mass="76.9199146" abundance="0.0763" />
      <isotope massNumber="78" mass="77.9173095" abundance="0.2377" />
      <isotope massNumber="80" mass="79.9165218" abundance="0.4961" />
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      <isotope massNumber="82" mass="81.9167" abundance="0.0873" />
    </isotopes>
  </element>
  <element symbol="Sg" name="Seaborgium" atomicNumber="106">
    <mass monoisotopic="266.12193" average="266.12193" />
    <isotopes>
      <isotope massNumber="266" mass="266.12193" abundance="1.0" />
    </isotopes>
  </element>
  <element symbol="Si" name="Silicon" atomicNumber="14">
    <mass monoisotopic="27.9769265327" average="28.0854128453" />
    <isotopes>
      <isotope massNumber="28" mass="27.9769265327" abundance="0.922297" />
      <isotope massNumber="29" mass="28.97649472" abundance="0.046832" />
      <isotope massNumber="30" mass="29.97377022" abundance="0.030872" />
    </isotopes>
  </element>
  <element symbol="Sm" name="Samarium" atomicNumber="62">
    <mass monoisotopic="151.919728" average="150.366344004" />
    <isotopes>
      <isotope massNumber="144" mass="143.911995" abundance="0.0307" />
      <isotope massNumber="147" mass="146.914893" abundance="0.1499" />
      <isotope massNumber="148" mass="147.914818" abundance="0.1124" />
      <isotope massNumber="149" mass="148.91718" abundance="0.1382" />
      <isotope massNumber="150" mass="149.917271" abundance="0.0738" />
      <isotope massNumber="152" mass="151.919728" abundance="0.2675" />
      <isotope massNumber="154" mass="153.922205" abundance="0.2275" />
    </isotopes>
  </element>
  <element symbol="Sn" name="Tin" atomicNumber="50">
    <mass monoisotopic="119.9021966" average="118.710110491" />
    <isotopes>
      <isotope massNumber="112" mass="111.904821" abundance="0.0097" />
      <isotope massNumber="114" mass="113.902782" abundance="0.0066" />
      <isotope massNumber="115" mass="114.903346" abundance="0.0034" />
      <isotope massNumber="116" mass="115.901744" abundance="0.1454" />
      <isotope massNumber="117" mass="116.902954" abundance="0.0768" />
      <isotope massNumber="118" mass="117.901606" abundance="0.2422" />
      <isotope massNumber="119" mass="118.903309" abundance="0.0859" />
      <isotope massNumber="120" mass="119.9021966" abundance="0.3258" />
      <isotope massNumber="122" mass="121.9034401" abundance="0.0463" />
      <isotope massNumber="124" mass="123.9052746" abundance="0.0579" />
    </isotopes>
  </element>
  <element symbol="Sr" name="Strontium" atomicNumber="38">
    <mass monoisotopic="87.9056143" average="87.6166462926" />
    <isotopes>
      <isotope massNumber="84" mass="83.913425" abundance="0.0056" />
      <isotope massNumber="86" mass="85.9092624" abundance="0.0986" />
      <isotope massNumber="87" mass="86.9088793" abundance="0.07" />
      <isotope massNumber="88" mass="87.9056143" abundance="0.8258" />
    </isotopes>
  </element>
  <element symbol="Ta" name="Tantalum" atomicNumber="73">
    <mass monoisotopic="180.947996" average="180.947875936" />
    <isotopes>
      <isotope massNumber="180" mass="179.947466" abundance="0.00012" />
      <isotope massNumber="181" mass="180.947996" abundance="0.99988" />
    </isotopes>
  </element>
  <element symbol="Tb" name="Terbium" atomicNumber="65">
    <mass monoisotopic="158.925343" average="158.925343" />
    <isotopes>
      <isotope massNumber="159" mass="158.925343" abundance="1.0" />
    </isotopes>
  </element>
  <element symbol="Tc" name="Technetium" atomicNumber="43">
    <mass monoisotopic="97.907216" average="97.907216" />
    <isotopes>
      <isotope massNumber="97" mass="96.906365" abundance="0.0" />
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      <isotope massNumber="98" mass="97.907216" abundance="1.0" />
      <isotope massNumber="99" mass="98.9062546" abundance="0.0" />
    </isotopes>
  </element>
  <element symbol="Te" name="Tellurium" atomicNumber="52">
    <mass monoisotopic="129.9062228" average="127.603125354" />
    <isotopes>
      <isotope massNumber="120" mass="119.90402" abundance="0.0009" />
      <isotope massNumber="122" mass="121.9030471" abundance="0.0255" />
      <isotope massNumber="123" mass="122.904273" abundance="0.0089" />
      <isotope massNumber="124" mass="123.9028195" abundance="0.0474" />
      <isotope massNumber="125" mass="124.9044247" abundance="0.0707" />
      <isotope massNumber="126" mass="125.9033055" abundance="0.1884" />
      <isotope massNumber="128" mass="127.9044614" abundance="0.3174" />
      <isotope massNumber="130" mass="129.9062228" abundance="0.3408" />
    </isotopes>
  </element>
  <element symbol="Th" name="Thorium" atomicNumber="90">
    <mass monoisotopic="230.0331266" average="765.802546733" />
    <isotopes>
      <isotope massNumber="230" mass="230.0331266" abundance="2.320381" />
      <isotope massNumber="232" mass="232.0380504" abundance="1.0" />
    </isotopes>
  </element>
  <element symbol="Ti" name="Titanium" atomicNumber="22">
    <mass monoisotopic="47.9479471" average="47.8667498036" />
    <isotopes>
      <isotope massNumber="46" mass="45.9526295" abundance="0.0825" />
      <isotope massNumber="47" mass="46.9517638" abundance="0.0744" />
      <isotope massNumber="48" mass="47.9479471" abundance="0.7372" />
      <isotope massNumber="49" mass="48.9478708" abundance="0.0541" />
      <isotope massNumber="50" mass="49.9447921" abundance="0.0518" />
    </isotopes>
  </element>
  <element symbol="Tl" name="Thallium" atomicNumber="81">
    <mass monoisotopic="204.974412" average="204.383317015" />
    <isotopes>
      <isotope massNumber="203" mass="202.972329" abundance="0.29524" />
      <isotope massNumber="205" mass="204.974412" abundance="0.70476" />
    </isotopes>
  </element>
  <element symbol="Tm" name="Thulium" atomicNumber="69">
    <mass monoisotopic="168.934211" average="168.934211" />
    <isotopes>
      <isotope massNumber="169" mass="168.934211" abundance="1.0" />
    </isotopes>
  </element>
  <element symbol="U" name="Uranium" atomicNumber="92">
    <mass monoisotopic="233.039628" average="792.730599067" />
    <isotopes>
      <isotope massNumber="233" mass="233.039628" abundance="2.3802891" />
      <isotope massNumber="234" mass="234.0409456" abundance="5.5e-05" />
      <isotope massNumber="235" mass="235.0439231" abundance="0.0072" />
      <isotope massNumber="236" mass="236.0455619" abundance="0.0" />
      <isotope massNumber="238" mass="238.0507826" abundance="0.992745" />
    </isotopes>
  </element>
  <element symbol="V" name="Vanadium" atomicNumber="23">
    <mass monoisotopic="50.9439637" average="50.9414716978" />
    <isotopes>
      <isotope massNumber="50" mass="49.9471628" abundance="0.0025" />
      <isotope massNumber="51" mass="50.9439637" abundance="0.9975" />
    </isotopes>
  </element>
  <element symbol="W" name="Tungsten" atomicNumber="74">
    <mass monoisotopic="183.9509326" average="183.841778628" />
    <isotopes>
      <isotope massNumber="180" mass="179.946706" abundance="0.0012" />
      <isotope massNumber="182" mass="181.948206" abundance="0.265" />
      <isotope massNumber="183" mass="182.9502245" abundance="0.1431" />
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      <isotope massNumber="184" mass="183.9509326" abundance="0.3064" />
      <isotope massNumber="186" mass="185.954362" abundance="0.2843" />
    </isotopes>
  </element>
  <element symbol="Xe" name="Xenon" atomicNumber="54">
    <mass monoisotopic="131.9041545" average="131.292480845" />
    <isotopes>
      <isotope massNumber="124" mass="123.9058958" abundance="0.0009" />
      <isotope massNumber="126" mass="125.904269" abundance="0.0009" />
      <isotope massNumber="128" mass="127.9035304" abundance="0.0192" />
      <isotope massNumber="129" mass="128.9047795" abundance="0.2644" />
      <isotope massNumber="130" mass="129.9035079" abundance="0.0408" />
      <isotope massNumber="131" mass="130.9050819" abundance="0.2118" />
      <isotope massNumber="132" mass="131.9041545" abundance="0.2689" />
      <isotope massNumber="134" mass="133.9053945" abundance="0.1044" />
      <isotope massNumber="136" mass="135.90722" abundance="0.0887" />
    </isotopes>
  </element>
  <element symbol="Y" name="Yttrium" atomicNumber="39">
    <mass monoisotopic="88.9058479" average="88.9058479" />
    <isotopes>
      <isotope massNumber="89" mass="88.9058479" abundance="1.0" />
    </isotopes>
  </element>
  <element symbol="Yb" name="Ytterbium" atomicNumber="70">
    <mass monoisotopic="173.9388581" average="173.037691736" />
    <isotopes>
      <isotope massNumber="168" mass="167.933894" abundance="0.0013" />
      <isotope massNumber="170" mass="169.934759" abundance="0.0304" />
      <isotope massNumber="171" mass="170.936322" abundance="0.1428" />
      <isotope massNumber="172" mass="171.9363777" abundance="0.2183" />
      <isotope massNumber="173" mass="172.9382068" abundance="0.1613" />
      <isotope massNumber="174" mass="173.9388581" abundance="0.3183" />
      <isotope massNumber="176" mass="175.942568" abundance="0.1276" />
    </isotopes>
  </element>
  <element symbol="Zn" name="Zinc" atomicNumber="30">
    <mass monoisotopic="63.9291466" average="65.3955665657" />
    <isotopes>
      <isotope massNumber="64" mass="63.9291466" abundance="0.4863" />
      <isotope massNumber="66" mass="65.9260368" abundance="0.279" />
      <isotope massNumber="67" mass="66.9271309" abundance="0.041" />
      <isotope massNumber="68" mass="67.9248476" abundance="0.1875" />
      <isotope massNumber="70" mass="69.925325" abundance="0.0062" />
    </isotopes>
  </element>
  <element symbol="Zr" name="Zirconium" atomicNumber="40">
    <mass monoisotopic="89.9047037" average="91.2236472138" />
    <isotopes>
      <isotope massNumber="90" mass="89.9047037" abundance="0.5145" />
      <isotope massNumber="91" mass="90.905645" abundance="0.1122" />
      <isotope massNumber="92" mass="91.9050401" abundance="0.1715" />
      <isotope massNumber="94" mass="93.9063158" abundance="0.1738" />
      <isotope massNumber="96" mass="95.908276" abundance="0.028" />
    </isotopes>
  </element>
</mspyElements>

19.2. Amino acids

Configuration file “aminoacids.xml” contains all the amino acids available for sequence editing.

<?xml version="1.0" encoding="utf-8" ?>
<mspyAminoacids version="1.0">
  <aminoacid symbol="A" name="Alanine" abbr="Ala" formula="C3H5NO" />
  <aminoacid symbol="C" name="Cysteine" abbr="Cys" formula="C3H5NOS" />
  <aminoacid symbol="D" name="Aspartic Acid" abbr="Asp" formula="C4H5NO3" />
  <aminoacid symbol="E" name="Glutamic Acid" abbr="Glu" formula="C5H7NO3" />
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  <aminoacid symbol="F" name="Phenylalanine" abbr="Phe" formula="C9H9NO" />
  <aminoacid symbol="G" name="Glycine" abbr="Gly" formula="C2H3NO" />
  <aminoacid symbol="H" name="Histidine" abbr="His" formula="C6H7N3O" />
  <aminoacid symbol="I" name="Isoleucine" abbr="Ile" formula="C6H11NO" />
  <aminoacid symbol="K" name="Lysine" abbr="Lys" formula="C6H12N2O" />
  <aminoacid symbol="L" name="Leucine" abbr="Leu" formula="C6H11NO" />
  <aminoacid symbol="M" name="Methionine" abbr="Met" formula="C5H9NSO" />
  <aminoacid symbol="N" name="Asparagine" abbr="Asn" formula="C4H6O2N2" />
  <aminoacid symbol="P" name="Proline" abbr="Pro" formula="C5H7NO" />
  <aminoacid symbol="Q" name="Glutamine" abbr="Gln" formula="C5H8N2O2" />
  <aminoacid symbol="R" name="Arginine" abbr="Arg" formula="C6H12N4O" />
  <aminoacid symbol="S" name="Serine" abbr="Ser" formula="C3H5NO2" />
  <aminoacid symbol="T" name="Threonine" abbr="Thr" formula="C4H7NO2" />
  <aminoacid symbol="V" name="Valine" abbr="Val" formula="C5H9NO" />
  <aminoacid symbol="W" name="Tryptophan" abbr="Trp" formula="C11H10N2O" />
  <aminoacid symbol="Y" name="Tyrosine" abbr="Tyr" formula="C9H9NO2" />
</mspyAminoacids>

19.3. Fragments

Configuration file “fragments.xml” contains all the fragments definitions for peptides fragmentation.

<?xml version="1.0" encoding="utf-8" ?>
<mspyFragments version="1.0">
  <fragment name="a" terminus="N" specifity="ACDEFGHIKLMNPQRSTVYW">
    <formula nTerm="" cTerm="C-1O-1H-1" neutralLoss="" />
    <termFilter nTerm="1" cTerm="1" />
  </fragment>
  <fragment name="a-H2O" terminus="N" specifity="STED">
    <formula nTerm="" cTerm="C-1O-1H-1" neutralLoss="H2O" />
    <termFilter nTerm="1" cTerm="1" />
  </fragment>
  <fragment name="a-NH3" terminus="N" specifity="RKQN">
    <formula nTerm="" cTerm="C-1O-1H-1" neutralLoss="NH3" />
    <termFilter nTerm="1" cTerm="1" />
  </fragment>
  <fragment name="b" terminus="N" specifity="ACDEFGHIKLMNPQRSTVYW">
    <formula nTerm="" cTerm="H-1" neutralLoss="" />
    <termFilter nTerm="1" cTerm="1" />
  </fragment>
  <fragment name="b-H2O" terminus="N" specifity="STED">
    <formula nTerm="" cTerm="H-1" neutralLoss="H2O" />
    <termFilter nTerm="1" cTerm="1" />
  </fragment>
  <fragment name="b-NH3" terminus="N" specifity="RKQN">
    <formula nTerm="" cTerm="H-1" neutralLoss="NH3" />
    <termFilter nTerm="1" cTerm="1" />
  </fragment>
  <fragment name="c" terminus="N" specifity="ACDEFGHIKLMNPQRSTVYW">
    <formula nTerm="" cTerm="NH2" neutralLoss="" />
    <termFilter nTerm="1" cTerm="1" />
  </fragment>
  <fragment name="c-ladder" terminus="N" specifity="ACDEFGHIKLMNPQRSTVYW">
    <formula nTerm="" cTerm="OH" neutralLoss="" />
    <termFilter nTerm="0" cTerm="1" />
  </fragment>
  <fragment name="im" terminus="S" specifity="ACDEFGHIKLMNPQRSTVYW">
    <formula nTerm="H" cTerm="C-1O-1H-1" neutralLoss="" />
    <termFilter nTerm="1" cTerm="0" />
  </fragment>
  <fragment name="int" terminus="I" specifity="ACDEFGHIKLMNPQRSTVYW">
    <formula nTerm="H" cTerm="H-1" neutralLoss="" />
    <termFilter nTerm="0" cTerm="0" />
  </fragment>
  <fragment name="int-CO" terminus="I" specifity="ACDEFGHIKLMNPQRSTVYW">
    <formula nTerm="H" cTerm="C-1O-1H-1" neutralLoss="" />
    <termFilter nTerm="0" cTerm="0" />
  </fragment>
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  <fragment name="int-H2O" terminus="I" specifity="STED">
    <formula nTerm="H" cTerm="H-1" neutralLoss="H2O" />
    <termFilter nTerm="0" cTerm="0" />
  </fragment>
  <fragment name="int-NH3" terminus="I" specifity="RKQN">
    <formula nTerm="H" cTerm="H-1" neutralLoss="NH3" />
    <termFilter nTerm="0" cTerm="0" />
  </fragment>
  <fragment name="n-ladder" terminus="C" specifity="ACDEFGHIKLMNPQRSTVYW">
    <formula nTerm="H" cTerm="" neutralLoss="" />
    <termFilter nTerm="1" cTerm="0" />
  </fragment>
  <fragment name="x" terminus="C" specifity="ACDEFGHIKLMNPQRSTVYW">
    <formula nTerm="COH-1" cTerm="" neutralLoss="" />
    <termFilter nTerm="0" cTerm="1" />
  </fragment>
  <fragment name="y" terminus="C" specifity="ACDEFGHIKLMNPQRSTVYW">
    <formula nTerm="H" cTerm="" neutralLoss="" />
    <termFilter nTerm="1" cTerm="0" />
  </fragment>
  <fragment name="y-H2O" terminus="C" specifity="STED">
    <formula nTerm="H" cTerm="" neutralLoss="H2O" />
    <termFilter nTerm="1" cTerm="0" />
  </fragment>
  <fragment name="y-NH3" terminus="C" specifity="RKQN">
    <formula nTerm="H" cTerm="" neutralLoss="NH3" />
    <termFilter nTerm="1" cTerm="0" />
  </fragment>
  <fragment name="z" terminus="C" specifity="ACDEFGHIKLMNPQRSTVYW">
    <formula nTerm="N-1H-1" cTerm="" neutralLoss="" />
    <termFilter nTerm="1" cTerm="0" />
  </fragment>
</mspyFragments>

19.4. Enzymes

Configuration file “enzymes.xml” contains all the enzymes definitions for protein digestion.

<?xml version="1.0" encoding="utf-8" ?>
<mspyEnzymes version="1.0">
  <enzyme name="Arg-C">
    <expression><![CDATA[[R][A-Z]]]></expression>
    <formula nTerm="H" cTerm="OH" />
    <allowMods before="0" after="1" />
  </enzyme>
  <enzyme name="Asp-N">
    <expression><![CDATA[[A-Z][D]]]></expression>
    <formula nTerm="H" cTerm="OH" />
    <allowMods before="1" after="0" />
  </enzyme>
  <enzyme name="Bromelain">
    <expression><![CDATA[[KAY][A-Z]]]></expression>
    <formula nTerm="H" cTerm="OH" />
    <allowMods before="0" after="1" />
  </enzyme>
  <enzyme name="CNBr-HSerLac">
    <expression><![CDATA[[M][A-Z]]]></expression>
    <formula nTerm="H" cTerm="O-1C-1H-3" />
    <allowMods before="0" after="1" />
  </enzyme>
  <enzyme name="Cathepsin B">
    <expression><![CDATA[[R][A-Z]]]></expression>
    <formula nTerm="H" cTerm="OH" />
    <allowMods before="0" after="1" />
  </enzyme>
  <enzyme name="Cathepsin D">
    <expression><![CDATA[[LF][^VAG]]]></expression>
    <formula nTerm="H" cTerm="OH" />
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    <allowMods before="0" after="1" />
  </enzyme>
  <enzyme name="Cathepsin G">
    <expression><![CDATA[[YWF][A-Z]]]></expression>
    <formula nTerm="H" cTerm="OH" />
    <allowMods before="0" after="1" />
  </enzyme>
  <enzyme name="Chymotrypsin">
    <expression><![CDATA[[YWFL][^P]]]></expression>
    <formula nTerm="H" cTerm="OH" />
    <allowMods before="0" after="1" />
  </enzyme>
  <enzyme name="Clostripain">
    <expression><![CDATA[[R][^P]]]></expression>
    <formula nTerm="H" cTerm="OH" />
    <allowMods before="0" after="1" />
  </enzyme>
  <enzyme name="Elastase">
    <expression><![CDATA[[AVLIGS][A-Z]]]></expression>
    <formula nTerm="H" cTerm="OH" />
    <allowMods before="0" after="1" />
  </enzyme>
  <enzyme name="Glu-C Bic">
    <expression><![CDATA[[E][A-Z]]]></expression>
    <formula nTerm="H" cTerm="OH" />
    <allowMods before="0" after="1" />
  </enzyme>
  <enzyme name="Glu-C Phos">
    <expression><![CDATA[[ED][A-Z]]]></expression>
    <formula nTerm="H" cTerm="OH" />
    <allowMods before="0" after="1" />
  </enzyme>
  <enzyme name="Hydroxylamine">
    <expression><![CDATA[[N][G]]]></expression>
    <formula nTerm="H" cTerm="OH" />
    <allowMods before="0" after="0" />
  </enzyme>
  <enzyme name="Lys-C">
    <expression><![CDATA[[K][A-Z]]]></expression>
    <formula nTerm="H" cTerm="OH" />
    <allowMods before="0" after="1" />
  </enzyme>
  <enzyme name="Lys-N">
    <expression><![CDATA[[A-Z][K]]]></expression>
    <formula nTerm="H" cTerm="OH" />
    <allowMods before="1" after="0" />
  </enzyme>
  <enzyme name="Non-Specific">
    <expression><![CDATA[[A-Z][A-Z]]]></expression>
    <formula nTerm="H" cTerm="OH" />
    <allowMods before="1" after="1" />
  </enzyme>
  <enzyme name="Papain">
    <expression><![CDATA[[RK][A-Z]]]></expression>
    <formula nTerm="H" cTerm="OH" />
    <allowMods before="0" after="1" />
  </enzyme>
  <enzyme name="Pepsin">
    <expression><![CDATA[[LF][^VAG]]]></expression>
    <formula nTerm="H" cTerm="OH" />
    <allowMods before="0" after="1" />
  </enzyme>
  <enzyme name="Proteinase K">
    <expression><![CDATA[[YWF][A-Z]]]></expression>
    <formula nTerm="H" cTerm="OH" />
    <allowMods before="0" after="1" />
  </enzyme>
  <enzyme name="Subtilisin">
    <expression><![CDATA[[^RHK][A-Z]]]></expression>
    <formula nTerm="H" cTerm="OH" />
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    <allowMods before="0" after="1" />
  </enzyme>
  <enzyme name="Thermolysin">
    <expression><![CDATA[[A-Z][LFIVMA]]]></expression>
    <formula nTerm="H" cTerm="OH" />
    <allowMods before="1" after="0" />
  </enzyme>
  <enzyme name="TrypAspN">
    <expression><![CDATA[(([KR][^P])|([A-Z][D]))]]></expression>
    <formula nTerm="H" cTerm="OH" />
    <allowMods before="0" after="0" />
  </enzyme>
  <enzyme name="TrypChymo">
    <expression><![CDATA[[FYWLKR][^P]]]></expression>
    <formula nTerm="H" cTerm="OH" />
    <allowMods before="0" after="1" />
  </enzyme>
  <enzyme name="Trypsin">
    <expression><![CDATA[[KR][^P]]]></expression>
    <formula nTerm="H" cTerm="OH" />
    <allowMods before="0" after="1" />
  </enzyme>
  <enzyme name="Trypsin/P">
    <expression><![CDATA[[KR][A-Z]]]></expression>
    <formula nTerm="H" cTerm="OH" />
    <allowMods before="0" after="1" />
  </enzyme>
</mspyEnzymes>
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